<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN" "http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" dir="ltr" xml:lang="en-US">
    <head>
        <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
        <title>
           This Weekend: Festivals, mysteries, concerts, walks &amp; more | Shelton Herald     
</title>
        <link rel="profile" href="http://gmpg.org/xfn/11" />
        <link rel="shortcut icon" href="http://sheltonherald.hanewsmedia.com/wp-content/uploads/sites/33/2015/09/SH-favicon.png" type="image/x-icon" />		<link rel="stylesheet" href="http://www.sheltonherald.com/wp-content/themes/unspoken-sh/style.css" type="text/css" media="all" />
		<link rel="stylesheet" href="http://www.sheltonherald.com/wp-content/themes/unspoken-sh/lib/js/fancybox/jquery.fancybox-1.3.4.css" type="text/css" media="all" />
        <link rel="pingback" href="http://www.sheltonherald.com/xmlrpc.php" />
        <link rel="alternate" type="text/xml" title="RSS .92" href="http://www.sheltonherald.com/feed/rss/"/>
        <link rel="alternate" type="application/atom+xml" title="Atom 0.3" href="http://www.sheltonherald.com/feed/atom/" />
		<!--[if lt IE 8]><link rel="stylesheet" href="http://www.sheltonherald.com/wp-content/themes/unspoken-sh/ie.css" type="text/css" media="all" /><![endif]-->

        
        
        <link rel="canonical" href="http://arts.hersamacorn.com/2017/09/28/this-weekend-festivals-mysteries-concerts-walks-more/" />

<!-- This site is optimized with the Yoast SEO Premium plugin v2.3.4 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="Film festival in Danbury The 20th annual Manhattan Short Film Festival takes place Sept. 28 through Oct. 8 at The Palace Danbury, 165 Main Street in Danbur"/>
<link rel="publisher" href="https://plus.google.com/+SheltonHerald/about"/>
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="This Weekend: Festivals, mysteries, concerts, walks &amp; more | Shelton Herald" />
<meta property="og:description" content="Film festival in Danbury The 20th annual Manhattan Short Film Festival takes place Sept. 28 through Oct. 8 at The Palace Danbury, 165 Main Street in Danbur" />
<meta property="og:site_name" content="Shelton Herald" />
<meta property="article:publisher" content="https://www.facebook.com/SheltonHerald" />
<meta property="article:tag" content="art" />
<meta property="article:tag" content="arts" />
<meta property="article:tag" content="concerts" />
<meta property="article:tag" content="exhibits" />
<meta property="article:tag" content="music" />
<meta property="article:tag" content="plays" />
<meta property="article:tag" content="theater" />
<meta property="article:tag" content="this weekend" />
<meta property="article:section" content="This Weekend &amp; Coming Up" />
<meta property="article:published_time" content="2017-09-28T14:09:20+00:00" />
<meta property="article:modified_time" content="2017-09-28T10:52:47+00:00" />
<meta property="og:updated_time" content="2017-09-28T10:52:47+00:00" />
<meta property="og:image" content="http://sheltonherald.hanewsmedia.com/wp-content/uploads/sites/33/2017/09/P1-Bridgeport-9-28.jpg" />
<meta name="twitter:card" content="summary_large_image"/>
<meta name="twitter:description" content="Film festival in Danbury The 20th annual Manhattan Short Film Festival takes place Sept. 28 through Oct. 8 at The Palace Danbury, 165 Main Street in Danbur"/>
<meta name="twitter:title" content="This Weekend: Festivals, mysteries, concerts, walks &amp; more | Shelton Herald"/>
<meta name="twitter:site" content="@sheltonherald"/>
<meta name="twitter:domain" content="Shelton Herald"/>
<meta name="twitter:image:src" content="http://sheltonherald.hanewsmedia.com/wp-content/uploads/sites/33/2017/09/P1-Bridgeport-9-28.jpg"/>
<meta name="twitter:creator" content="@sheltonherald"/>
<!-- / Yoast SEO Premium plugin. -->

<link rel='dns-prefetch' href='//sheltonherald.hanewsmedia.com' />
<link rel='dns-prefetch' href='//platform.twitter.com' />
<link rel='dns-prefetch' href='//apis.google.com' />
<link rel='dns-prefetch' href='//platform.linkedin.com' />
<link rel='dns-prefetch' href='//www.sheltonherald.com' />
<link rel='dns-prefetch' href='//p.jwpcdn.com' />
<link rel='dns-prefetch' href='//cdn.datatables.net' />
<link rel='dns-prefetch' href='//cdn.rawgit.com' />
<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//www.google.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Shelton Herald &raquo; Feed" href="http://www.sheltonherald.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Shelton Herald &raquo; Comments Feed" href="http://www.sheltonherald.com/comments/feed/" />
<link rel="alternate" type="text/calendar" title="Shelton Herald &raquo; iCal Feed" href="http://www.sheltonherald.com/events/?ical=1" />
<link rel="alternate" type="application/rss+xml" title="Shelton Herald &raquo; This Weekend: Festivals, mysteries, concerts, walks &#038; more Comments Feed" href="http://www.sheltonherald.com/104374/this-weekend-festivals-mysteries-concerts-walks-more/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.sheltonherald.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=8f576fb9c9fac88b2ded0a8fddab59ce"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b!==c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='yarppWidgetCss-css'  href='http://www.sheltonherald.com/wp-content/plugins/yet-another-related-posts-plugin/style/widget.css?ver=8f576fb9c9fac88b2ded0a8fddab59ce' type='text/css' media='all' />
<link rel='stylesheet' id='scap.flashblock-css'  href='http://sheltonherald.hanewsmedia.com/wp-content/plugins/compact-wp-audio-player/css/flashblock.css?ver=8f576fb9c9fac88b2ded0a8fddab59ce' type='text/css' media='all' />
<link rel='stylesheet' id='scap.player-css'  href='http://sheltonherald.hanewsmedia.com/wp-content/plugins/compact-wp-audio-player/css/player.css?ver=8f576fb9c9fac88b2ded0a8fddab59ce' type='text/css' media='all' />
<link rel='stylesheet' id='tfg_style-css'  href='http://www.sheltonherald.com/wp-content/plugins/twitter-facebook-google-plusone-share/tfg_style.css?ver=8f576fb9c9fac88b2ded0a8fddab59ce' type='text/css' media='all' />
<link rel='stylesheet' id='cpsh-shortcodes-css'  href='http://www.sheltonherald.com/wp-content/plugins/column-shortcodes//assets/css/shortcodes.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='advpsStyleSheet-css'  href='http://sheltonherald.hanewsmedia.com/wp-content/plugins/advanced-post-slider/advps-style.css?ver=8f576fb9c9fac88b2ded0a8fddab59ce' type='text/css' media='all' />
<link rel='stylesheet' id='jquery-datatables-css'  href='//cdn.datatables.net/1.10.12/css/jquery.dataTables.min.css?ver=8f576fb9c9fac88b2ded0a8fddab59ce' type='text/css' media='all' />
<link rel='stylesheet' id='datatables-buttons-css'  href='//cdn.datatables.net/buttons/1.2.1/css/buttons.dataTables.min.css?ver=8f576fb9c9fac88b2ded0a8fddab59ce' type='text/css' media='all' />
<link rel='stylesheet' id='datatables-select-css'  href='//cdn.datatables.net/select/1.2.0/css/select.dataTables.min.css?ver=8f576fb9c9fac88b2ded0a8fddab59ce' type='text/css' media='all' />
<link rel='stylesheet' id='datatables-fixedheader-css'  href='//cdn.datatables.net/fixedheader/3.1.2/css/fixedHeader.dataTables.min.css?ver=8f576fb9c9fac88b2ded0a8fddab59ce' type='text/css' media='all' />
<link rel='stylesheet' id='datatables-fixedcolumns-css'  href='//cdn.datatables.net/fixedcolumns/3.2.2/css/fixedColumns.dataTables.min.css?ver=8f576fb9c9fac88b2ded0a8fddab59ce' type='text/css' media='all' />
<link rel='stylesheet' id='datatables-responsive-css'  href='//cdn.datatables.net/responsive/2.1.0/css/responsive.dataTables.min.css?ver=8f576fb9c9fac88b2ded0a8fddab59ce' type='text/css' media='all' />
<link rel='stylesheet' id='ce_responsive-css'  href='http://www.sheltonherald.com/wp-content/plugins/simple-embed-code/css/video-container.css?ver=8f576fb9c9fac88b2ded0a8fddab59ce' type='text/css' media='all' />
<link rel='stylesheet' id='__EPYT__style-css'  href='http://www.sheltonherald.com/wp-content/plugins/youtube-embed-plus-pro/styles/ytprefs.min.css?ver=8f576fb9c9fac88b2ded0a8fddab59ce' type='text/css' media='all' />
<style id='__EPYT__style-inline-css' type='text/css'>

                .epyt-gallery-thumb {
                        width: 33.333%;
                }
                
</style>
<link rel='stylesheet' id='__disptype__-css'  href='http://www.sheltonherald.com/wp-content/plugins/youtube-embed-plus-pro/scripts/lity.min.css?ver=8f576fb9c9fac88b2ded0a8fddab59ce' type='text/css' media='all' />
<link rel='stylesheet' id='wpmu-animate-min-css-css'  href='http://sheltonherald.hanewsmedia.com/wp-content/plugins/popover/css/animate.min.css?ver=8f576fb9c9fac88b2ded0a8fddab59ce' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://www.sheltonherald.com/wp-content/plugins/jetpack/css/jetpack.css?ver=5.3' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var tribe_events_linked_posts = {"post_types":{"tribe_venue":"venue","tribe_organizer":"organizer"}};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.sheltonherald.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://www.sheltonherald.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://sheltonherald.hanewsmedia.com/wp-content/plugins/compact-wp-audio-player/js/soundmanager2-nodebug-jsmin.js?ver=8f576fb9c9fac88b2ded0a8fddab59ce'></script>
<script type='text/javascript' src='http://www.sheltonherald.com/wp-content/themes/unspoken-sh/lib/js/jcarousellite_1.0.1_mod.js?ver=8f576fb9c9fac88b2ded0a8fddab59ce'></script>
<script type='text/javascript' src='http://www.sheltonherald.com/wp-content/themes/unspoken-sh/lib/js/fancybox/jquery.fancybox-1.3.4.pack.js?ver=8f576fb9c9fac88b2ded0a8fddab59ce'></script>
<script type='text/javascript' src='http://www.sheltonherald.com/wp-content/themes/unspoken-sh/lib/js/scripts.js?ver=8f576fb9c9fac88b2ded0a8fddab59ce'></script>
<script type='text/javascript' src='http://www.sheltonherald.com/wp-content/themes/unspoken-sh/lib/js/jquery.infinitescroll.init.js?ver=8f576fb9c9fac88b2ded0a8fddab59ce'></script>
<script type='text/javascript' src='http://p.jwpcdn.com/6/12/jwplayer.js?ver=8f576fb9c9fac88b2ded0a8fddab59ce'></script>
<script type='text/javascript' src='http://sheltonherald.hanewsmedia.com/wp-content/plugins/advanced-post-slider/js/advps.frnt.script.js?ver=8f576fb9c9fac88b2ded0a8fddab59ce'></script>
<script type='text/javascript' src='http://sheltonherald.hanewsmedia.com/wp-content/plugins/advanced-post-slider/bxslider/jquery.bxslider.min.js?ver=8f576fb9c9fac88b2ded0a8fddab59ce'></script>
<script type='text/javascript' src='//cdn.datatables.net/1.10.12/js/jquery.dataTables.min.js?ver=8f576fb9c9fac88b2ded0a8fddab59ce'></script>
<script type='text/javascript' src='//cdn.datatables.net/buttons/1.2.1/js/dataTables.buttons.min.js?ver=8f576fb9c9fac88b2ded0a8fddab59ce'></script>
<script type='text/javascript' src='//cdn.datatables.net/buttons/1.2.1/js/buttons.colVis.min.js?ver=8f576fb9c9fac88b2ded0a8fddab59ce'></script>
<script type='text/javascript' src='//cdn.datatables.net/buttons/1.2.1/js/buttons.print.min.js?ver=8f576fb9c9fac88b2ded0a8fddab59ce'></script>
<script type='text/javascript' src='//cdn.rawgit.com/bpampuch/pdfmake/0.1.18/build/pdfmake.min.js?ver=8f576fb9c9fac88b2ded0a8fddab59ce'></script>
<script type='text/javascript' src='//cdn.rawgit.com/bpampuch/pdfmake/0.1.18/build/vfs_fonts.js?ver=8f576fb9c9fac88b2ded0a8fddab59ce'></script>
<script type='text/javascript' src='//cdnjs.cloudflare.com/ajax/libs/jszip/2.5.0/jszip.min.js?ver=8f576fb9c9fac88b2ded0a8fddab59ce'></script>
<script type='text/javascript' src='//cdn.datatables.net/buttons/1.2.1/js/buttons.html5.min.js?ver=8f576fb9c9fac88b2ded0a8fddab59ce'></script>
<script type='text/javascript' src='//cdn.datatables.net/select/1.2.0/js/dataTables.select.min.js?ver=8f576fb9c9fac88b2ded0a8fddab59ce'></script>
<script type='text/javascript' src='//cdn.datatables.net/fixedheader/3.1.2/js/dataTables.fixedHeader.min.js?ver=8f576fb9c9fac88b2ded0a8fddab59ce'></script>
<script type='text/javascript' src='//cdn.datatables.net/fixedcolumns/3.2.2/js/dataTables.fixedColumns.min.js?ver=8f576fb9c9fac88b2ded0a8fddab59ce'></script>
<script type='text/javascript' src='//cdn.datatables.net/responsive/2.1.0/js/dataTables.responsive.min.js?ver=8f576fb9c9fac88b2ded0a8fddab59ce'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var igsv_plugin_vars = {"lang_dir":"http:\/\/www.sheltonherald.com\/wp-content\/plugins\/inline-google-spreadsheet-viewer\/languages","datatables_classes":".igsv-table:not(.no-datatables)","datatables_defaults_object":{"dom":"B<'clear'>lfrtip","buttons":[]}};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.sheltonherald.com/wp-content/plugins/inline-google-spreadsheet-viewer/igsv-datatables.js?ver=8f576fb9c9fac88b2ded0a8fddab59ce'></script>
<script type='text/javascript' src='//www.google.com/jsapi?ver=8f576fb9c9fac88b2ded0a8fddab59ce'></script>
<script type='text/javascript' src='http://www.sheltonherald.com/wp-content/plugins/inline-google-spreadsheet-viewer/igsv-gvizcharts.js?ver=8f576fb9c9fac88b2ded0a8fddab59ce'></script>
<script type='text/javascript' src='http://www.sheltonherald.com/wp-content/plugins/advanced-iframe/js/ai.js?ver=791455'></script>
<script type='text/javascript' src='http://www.sheltonherald.com/wp-content/plugins/youtube-embed-plus-pro/scripts/lity.min.js?ver=8f576fb9c9fac88b2ded0a8fddab59ce'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _EPYT_ = {"ajaxurl":"http:\/\/www.sheltonherald.com\/wp-admin\/admin-ajax.php","security":"4dd0b85d28","gallery_scrolloffset":"20","eppathtoscripts":"http:\/\/www.sheltonherald.com\/wp-content\/plugins\/youtube-embed-plus-pro\/scripts\/","epresponsiveselector":"[\"iframe[src*='youtube.com']\",\"iframe[src*='youtube-nocookie.com']\",\"iframe[data-ep-src*='youtube.com']\",\"iframe[data-ep-src*='youtube-nocookie.com']\",\"iframe[data-ep-gallerysrc*='youtube.com']\"]","epdovol":"1","version":"11.7.1","evselector":"iframe.__youtube_prefs__[src], iframe[src*=\"youtube.com\/embed\/\"], iframe[src*=\"youtube-nocookie.com\/embed\/\"]","stopMobileBuffer":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.sheltonherald.com/wp-content/plugins/youtube-embed-plus-pro/scripts/ytprefs.min.js?ver=8f576fb9c9fac88b2ded0a8fddab59ce'></script>
<link rel='https://api.w.org/' href='http://www.sheltonherald.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.sheltonherald.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.sheltonherald.com/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='http://bit.ly/2wYWXBF' />
<link rel="alternate" type="application/json+oembed" href="http://www.sheltonherald.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.sheltonherald.com%2F104374%2Fthis-weekend-festivals-mysteries-concerts-walks-more%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.sheltonherald.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.sheltonherald.com%2F104374%2Fthis-weekend-festivals-mysteries-concerts-walks-more%2F&#038;format=xml" />
<script type="text/javascript">jwplayer.defaults = { "ph": 2 };</script>

<!-- Facebook Like Thumbnail -->
<link rel="image_src" href="http://sheltonherald.hanewsmedia.com/wp-content/uploads/sites/33/2017/09/P1-Bridgeport-9-28.jpg" />
<!-- End Facebook Like Thumbnail -->

<link rel="alternate" type="application/rss+xml" title="Shelton Herald GeoRSS-Feed" href="http://sheltonherald.hanewsmedia.com/wp-content/plugins/leaflet-maps-marker/leaflet-georss.php?layer=all" />
<meta property="og:image" content="http://sheltonherald.hanewsmedia.com/wp-content/uploads/sites/33/2017/09/P1-Bridgeport-9-28-150x150.jpg" /><a href="https://plus.google.com/+SheltonHerald" rel="publisher" />

<script type='text/javascript'>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
var gads = document.createElement('script');
gads.async = true;
gads.type = 'text/javascript';
var useSSL = 'https:' == document.location.protocol;
gads.src = (useSSL ? 'https:' : 'http:') + 
'//www.googletagservices.com/tag/js/gpt.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(gads, node);
})();
</script>

<script type='text/javascript'>
googletag.cmd.push(function() {
googletag.defineSlot('/18392239/SheltonHerald-KristineLilly-Rectangle', [300, 75], 'div-gpt-ad-1350414041047-0').addService(googletag.pubads());
googletag.defineSlot('/18392239/SheltonHerald-KristineLilly-Square1', [300, 250], 'div-gpt-ad-1350414041047-1').addService(googletag.pubads());
googletag.defineSlot('/18392239/SheltonHerald-KristineLilly-Square2', [300, 250], 'div-gpt-ad-1350414041047-2').addService(googletag.pubads());
googletag.defineSlot('/18392239/SheltonHerald-KristineLilly-Square3', [300, 250], 'div-gpt-ad-1350414041047-3').addService(googletag.pubads());
googletag.defineSlot('/18392239/SheltonHeraldEarLeft', [180, 90], 'div-gpt-ad-1350414041047-4').addService(googletag.pubads());
googletag.defineSlot('/18392239/SheltonHeraldEarRight', [180, 90], 'div-gpt-ad-1350414041047-5').addService(googletag.pubads());
googletag.defineSlot('/18392239/SheltonHeraldRectangle1', [300, 75], 'div-gpt-ad-1350414041047-6').addService(googletag.pubads());
googletag.defineSlot('/18392239/SheltonHeraldRectangle2', [300, 75], 'div-gpt-ad-1350414041047-7').addService(googletag.pubads());
googletag.defineSlot('/18392239/SheltonHeraldRectangle3', [300, 75], 'div-gpt-ad-1350414041047-8').addService(googletag.pubads());
googletag.defineSlot('/18392239/SheltonHeraldSquare1', [300, 250], 'div-gpt-ad-1350414041047-9').addService(googletag.pubads());
googletag.defineSlot('/18392239/SheltonHeraldSquare2', [300, 250], 'div-gpt-ad-1350414041047-10').addService(googletag.pubads());
googletag.defineSlot('/18392239/SheltonHeraldSquare3', [300, 250], 'div-gpt-ad-1350414041047-11').addService(googletag.pubads());
googletag.defineSlot('/18392239/SheltonHeraldSquare4', [300, 250], 'div-gpt-ad-1350414041047-12').addService(googletag.pubads());
googletag.defineSlot('/18392239/SheltonHeraldNavBar', [728, 90], 'div-gpt-ad-1350414041047-13').addService(googletag.pubads());
googletag.defineSlot('/18392239/SheltonHeraldLocalYokelSquare', [300, 250], 'div-gpt-ad-1350414041047-14').addService(googletag.pubads());
googletag.defineSlot('/18392239/SheltonHeraldSplashAd', [600, 240], 'div-gpt-ad-1350414041047-15').addService(googletag.pubads());
googletag.defineSlot('/18392239/SheltonHeraldLocalYokelSpecial', [300, 250], 'div-gpt-ad-1350414041047-16').addService(googletag.pubads());
googletag.defineSlot('/18392239/SheltonHeraldSquare5', [300, 250], 'div-gpt-ad-1350414041047-17').addService(googletag.pubads());
googletag.defineSlot('/18392239/SheltonHeraldLargeSplash', [740, 510], 'div-gpt-ad-1448031815686-19').addService(googletag.pubads());

googletag.pubads().enableSingleRequest();
googletag.enableServices();
});
</script>

 <!-- Load Facebook SDK for JavaScript -->
  <div id="fb-root"></div>
  <script>(function(d, s, id) {
    var js, fjs = d.getElementsByTagName(s)[0];
    if (d.getElementById(id)) return;
    js = d.createElement(s); js.id = id;
    js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.6";
    fjs.parentNode.insertBefore(js, fjs);
  }(document, 'script', 'facebook-jssdk'));</script>

<style type="text/css">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</style>  

   
	</head>
	<body class="post-template-default single single-post postid-104374 single-format-standard tribe-bar-is-disabled">

        <div class="wrapper">
        
                        <div class="top-content-adplace">
                    <div id="execphp-5" class="widget_execphp">			<div class="execphpwidget"><!-- SheltonHeraldNavBar -->
<div id='div-gpt-ad-1350414041047-13' style='width:728px; height:90px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1350414041047-13'); });
</script>
</div></div>
		</div>                </div>
                                
            <div class="header">
                <div class="header-meta">

                    <div id="top-menu" class="menu-top-menu-container"><ul id="menu-top-menu" class="header-menu clear"><li id="menu-item-61047" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-61047"><a href="http://sheltonherald.com">Home</a></li>
<li id="menu-item-57574" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57574"><a target="_blank" href="https://classadz.vdata.com/HersamAcornCirc/SelectOption.aspx">Subscribe</a></li>
<li id="menu-item-61117" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-61117"><a target="_blank" href="http://sheltonherald.ct.newsmemory.com/">E-Edition</a></li>
<li id="menu-item-57577" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57577"><a target="_blank" href="http://sheltonherald.ct.newsmemory.com/marketplace.php">Marketplace</a></li>
<li id="menu-item-61120" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-61120"><a href="http://vermontnews-guide.com/">Visit Vermont</a></li>
<li id="menu-item-61127" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61127"><a href="http://www.sheltonherald.com/sign-up-for-email-alerts/">Sign up for Email Alerts</a></li>
<li id="menu-item-57575" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children parent menu-item-57575"><a href="http://#">Print Edition</a>
<ul  class="sub-menu">
	<li id="menu-item-57653" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57653"><a href="http://www.sheltonherald.com/shelton-newsstands/">Shelton Newsstands</a></li>
	<li id="menu-item-57576" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57576"><a target="_blank" href="https://classadz.vdata.com/HersamAcornCirc/SelectOption.aspx">Delivery Problems</a></li>
</ul>
</li>
<li id="menu-item-57578" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57578"><a target="_blank" href="http://www.hersamacorn.com/newspaper-advertising/">Advertise</a></li>
<li id="menu-item-61125" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children parent menu-item-61125"><a href="http://www.sheltonherald.com/help/">Help</a>
<ul  class="sub-menu">
	<li id="menu-item-61144" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61144"><a href="http://www.sheltonherald.com/about-us/">About Us</a></li>
	<li id="menu-item-61143" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61143"><a href="http://www.sheltonherald.com/contact-us/">Contact Us</a></li>
	<li id="menu-item-61146" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61146"><a href="http://www.sheltonherald.com/news-submission-guide/">News Submission Guide</a></li>
	<li id="menu-item-61145" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61145"><a href="http://www.sheltonherald.com/submissions/">Submissions</a></li>
</ul>
</li>
</ul></div>
                    <div class="header-searchform">
                        <form method="get" action="http://www.sheltonherald.com">
                            <fieldset>
                                <input type="text" id="s" name="s" onfocus="if(this.value=='Search') this.value='';" onblur="if(this.value=='') this.value='Search';" value="Search" />
                                <button type="submit"></button>
                            </fieldset>
                        </form>
                    </div>
                </div>
                <div class="header-middle clear">
                
                <div class="header-adplace-left">
                        <div id="header-adplace-left">			<div class="execphpwidget"><!-- SheltonHeraldEarLeft -->
<div id='div-gpt-ad-1350414041047-4' style='width:180px; height:90px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1350414041047-4'); });
</script>
</div></div>
		</div>                    </div>
                    <div class="logo-header ">
                        <a href="http://www.sheltonherald.com">
                        <img src="http://sheltonherald.hanewsmedia.com/wp-content/uploads/sites/33/2015/09/SH-MAST-405.png" alt="Shelton Herald"/>                        </a>
                    </div>
                    <div class="header-adplace-right">
                        <div id="header-adplace-right">			<div class="execphpwidget"><!-- SheltonHeraldEarRight -->
<div id='div-gpt-ad-1350414041047-5' style='width:180px; height:90px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1350414041047-5'); });
</script></div></div>
		</div>                      
                    </div>
                </div>
            </div>

						<div id="navigation" class="menu-navigation clear"><ul id="menu-navigation" class="menu"><li id="menu-item-61053" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children parent menu-item-61053"><a href="http://www.sheltonherald.com/category/news/">News</a>
<ul  class="sub-menu">
	<li id="menu-item-61124" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-61124"><a href="http://www.sheltonherald.com/category/news/police-fire/">Police &#038; Fire</a></li>
	<li id="menu-item-61068" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-61068"><a href="http://www.sheltonherald.com/category/news/business/">Business</a></li>
	<li id="menu-item-73810" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-73810"><a href="http://www.sheltonherald.com/category/news/community/">Community</a></li>
	<li id="menu-item-73811" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-73811"><a href="http://www.sheltonherald.com/category/news/entertainment/">Entertainment</a></li>
	<li id="menu-item-73812" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-73812"><a href="http://www.sheltonherald.com/category/news/people/">People</a></li>
	<li id="menu-item-61082" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-61082"><a href="http://www.sheltonherald.com/category/news/schools/">Schools</a></li>
	<li id="menu-item-61069" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-61069"><a href="http://www.sheltonherald.com/category/news/politics-elections/">Politics &#038; Elections</a></li>
	<li id="menu-item-61054" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-61054"><a target="_blank" href="http://www.hersamacorn.com/print-archives/">Print Archives</a></li>
	<li id="menu-item-61129" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61129"><a href="http://www.sheltonherald.com/submissions/">Submissions</a></li>
</ul>
</li>
<li id="menu-item-57609" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children parent menu-item-57609"><a href="http://sheltonherald.com/category/news/obituaries/">Obituaries</a>
<ul  class="sub-menu">
	<li id="menu-item-57605" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-57605"><a href="http://www.sheltonherald.com/category/obituaries/">Latest Obituaries</a></li>
	<li id="menu-item-57610" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57610"><a href="https://hersamsecure.com/obit/">Submit an Obituary</a></li>
</ul>
</li>
<li id="menu-item-57602" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children parent menu-item-57602"><a href="http://www.sheltonherald.com/category/sports/">Sports</a>
<ul  class="sub-menu">
	<li id="menu-item-57603" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-57603"><a href="http://www.sheltonherald.com/category/sports/high-school-sports/">High School Sports</a></li>
	<li id="menu-item-57604" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-57604"><a href="http://www.sheltonherald.com/category/sports/youth-sports/">Youth Sports</a></li>
	<li id="menu-item-73815" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-73815"><a href="http://www.sheltonherald.com/category/sports/sports-features/">Sports Features</a></li>
	<li id="menu-item-73814" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-73814"><a href="http://www.sheltonherald.com/category/sports/recreational-sports/">Recreational Sports</a></li>
	<li id="menu-item-73813" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-73813"><a href="http://www.sheltonherald.com/category/sports/other-sports/">Other Sports</a></li>
	<li id="menu-item-57657" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57657"><a href="http://www.sheltonherald.com/submissions/">Submissions</a></li>
</ul>
</li>
<li id="menu-item-61074" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-61074"><a href="http://www.sheltonherald.com/category/news/people/">People</a></li>
<li id="menu-item-61070" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children parent menu-item-61070"><a href="http://www.sheltonherald.com/category/opinion/">Opinion</a>
<ul  class="sub-menu">
	<li id="menu-item-61073" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-61073"><a href="http://www.sheltonherald.com/category/opinion/letters/">Letters</a></li>
	<li id="menu-item-61072" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-61072"><a href="http://www.sheltonherald.com/category/opinion/editorial/">Editorial</a></li>
	<li id="menu-item-61071" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children parent menu-item-61071"><a href="http://www.sheltonherald.com/category/opinion/columns/">Columns</a>
	<ul  class="sub-menu">
		<li id="menu-item-90211" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-90211"><a href="http://www.sheltonherald.com/category/opinion/columns/jim-cameron-talking-transportation/">Jim Cameron: Talking Transportation</a></li>
	</ul>
</li>
	<li id="menu-item-61131" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61131"><a href="http://www.sheltonherald.com/cartoon-gallery/">Cartoon Gallery</a></li>
</ul>
</li>
<li id="menu-item-73809" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children parent menu-item-73809"><a href="http://www.sheltonherald.com/events/">Happenings</a>
<ul  class="sub-menu">
	<li id="menu-item-61111" class="menu-item menu-item-type-taxonomy menu-item-object-tribe_events_cat menu-item-61111"><a href="http://www.sheltonherald.com/events/category/community-events/">Community Events</a></li>
	<li id="menu-item-61115" class="menu-item menu-item-type-taxonomy menu-item-object-tribe_events_cat menu-item-61115"><a href="http://www.sheltonherald.com/events/category/library-events/">Library Events</a></li>
	<li id="menu-item-61128" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61128"><a href="http://www.sheltonherald.com/submissions/">Submissions</a></li>
</ul>
</li>
<li id="menu-item-71040" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children parent menu-item-71040"><a href="http://www.sheltonherald.com/category/al-columns/food/">Food</a>
<ul  class="sub-menu">
	<li id="menu-item-71061" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-71061"><a href="http://www.sheltonherald.com/category/al-columns/al-twice-baked-twins/">Twins Judy &#038; Joy</a></li>
	<li id="menu-item-71056" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-71056"><a href="http://www.sheltonherald.com/category/al-columns/al-stir-crazy/">Stir Crazy</a></li>
	<li id="menu-item-71058" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-71058"><a href="http://www.sheltonherald.com/category/al-columns/al-the-conscious-cook/">The Conscious Cook</a></li>
</ul>
</li>
<li id="menu-item-71030" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children parent menu-item-71030"><a href="http://www.sheltonherald.com/category/al-features/">Arts</a>
<ul  class="sub-menu">
	<li id="menu-item-71033" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-71033"><a href="http://www.sheltonherald.com/category/al-features/">Arts Features</a></li>
	<li id="menu-item-71055" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-71055"><a href="http://www.sheltonherald.com/category/al-columns/al-stage-screen/">Stage &#038; Screen</a></li>
	<li id="menu-item-71035" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children parent menu-item-71035"><a href="http://www.sheltonherald.com/category/al-columns/">Columns</a>
	<ul  class="sub-menu">
		<li id="menu-item-71038" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-71038"><a href="http://www.sheltonherald.com/category/al-columns/al-did-i-say-that/">DId I Say That?</a></li>
		<li id="menu-item-71059" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-71059"><a href="http://www.sheltonherald.com/category/al-columns/al-the-reel-dad/">The Reel Dad</a></li>
		<li id="menu-item-71060" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-71060"><a href="http://www.sheltonherald.com/category/al-columns/al-tv-movie-menu/">TV / Movie Menu</a></li>
		<li id="menu-item-71037" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-71037"><a href="http://www.sheltonherald.com/category/al-columns/al-curtain-call/">Curtain Call</a></li>
		<li id="menu-item-71111" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-71111"><a href="http://www.sheltonherald.com/category/al-columns/al-stir-crazy/">Stir Crazy</a></li>
		<li id="menu-item-71113" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-71113"><a href="http://www.sheltonherald.com/category/al-columns/al-twice-baked-twins/">Twins Judy &#038; Joy</a></li>
		<li id="menu-item-71112" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-71112"><a href="http://www.sheltonherald.com/category/al-columns/al-the-conscious-cook/">The Conscious Cook</a></li>
		<li id="menu-item-71041" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-71041"><a href="http://www.sheltonherald.com/category/al-columns/al-go-fish/">Go Fish</a></li>
		<li id="menu-item-71057" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-71057"><a href="http://www.sheltonherald.com/category/al-columns/al-taking-a-hike/">Taking a Hike</a></li>
		<li id="menu-item-71036" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-71036"><a href="http://www.sheltonherald.com/category/al-columns/al-a-question-of-etiquette/">A Question of Etiquette</a></li>
	</ul>
</li>
	<li id="menu-item-71124" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-71124"><a href="http://arts.hersamacorn.com/events/">Events</a></li>
</ul>
</li>
<li id="menu-item-71039" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-71039"><a href="http://www.sheltonherald.com/category/al-columns/al-drive/">Automotive</a></li>
<li id="menu-item-61056" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children parent menu-item-61056"><a target="_blank" href="https://hersamsecure.com/classifieds/">Classifieds</a>
<ul  class="sub-menu">
	<li id="menu-item-61057" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-61057"><a target="_blank" href="http://www.hersamacorn.com/classifiedadvertising/">Advertising Information</a></li>
	<li id="menu-item-61058" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-61058"><a href="https://classadz.vdata.com/HersamAcorn/UserType.aspx">Submit a Classified Ad</a></li>
</ul>
</li>
<li id="menu-item-57585" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children parent menu-item-57585"><a href="http://#">Special Sections</a>
<ul  class="sub-menu">
	<li id="menu-item-103234" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-103234"><a href="http://backtoschool.han.network/">Back to School</a></li>
	<li id="menu-item-100571" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-100571"><a href="http://savor.han.network/">Savor</a></li>
	<li id="menu-item-100050" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-100050"><a href="http://greenlifestyles.han.network/">Green Lifestyle</a></li>
	<li id="menu-item-98390" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-98390"><a href="http://goldenyears.han.network/">Golden Years</a></li>
	<li id="menu-item-57589" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57589"><a target="_blank" href="http://kidsworld.han.network/">Kid&#8217;s World</a></li>
	<li id="menu-item-57636" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57636"><a target="_blank" href="http://healthandfitness.han.network/">Health &#038; Fitness</a></li>
	<li id="menu-item-57588" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57588"><a target="_blank" href="http://bridal.han.network/">Bridal</a></li>
	<li id="menu-item-57639" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57639"><a target="_blank" href="http://education.han.network/">Education</a></li>
	<li id="menu-item-57642" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57642"><a target="_blank" href="http://arts.hersamacorn.com">Arts &#038; Leisure</a></li>
	<li id="menu-item-57586" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57586"><a target="_blank" href="http://thehomemonthly.com">HOME</a></li>
	<li id="menu-item-57587" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57587"><a target="_blank" href="http://sheltonanswerbook.com">Shelton Answerbook</a></li>
	<li id="menu-item-57592" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57592"><a target="_blank" href="http://hersamacorn.com/medical-services/">Your Health</a></li>
</ul>
</li>
</ul></div>						
	          <div class="middle clear">

                

<div id="content">


<div id="post-104374" class="single post-104374 post type-post status-publish format-standard has-post-thumbnail hentry category-al-upcoming-arts-leisure tag-art tag-arts tag-concerts tag-exhibits-2 tag-music-2 tag-plays tag-theater tag-this-weekend">

    <div class="hentry-meta">
        <h1>This Weekend: Festivals, mysteries, concerts, walks &#038; more</h1>
<h2></h2>
        <p class="hentry-meta-data">By <a class="url fn n" href="http://www.sheltonherald.com/author/sally/" title="View all posts by Sally Sanders">Sally Sanders</a> on September 28, 2017 in <a href="http://www.sheltonherald.com/category/al-upcoming-arts-leisure/" rel="category tag">This Weekend &amp; Coming Up</a> &middot; <a href="#comments">0 Comments</a></p>
    </div>

    <div class="hentry-container clear">
                <div class="hentry-middle">
            <div class="hentry-content clear">
                <p><strong>Film festival in Danbury</strong></p>
<p><span style="font-weight: 400;">The 20th annual Manhattan Short Film Festival takes place Sept. 28 through Oct. 8 at The Palace Danbury, 165 Main Street in Danbury. The festival starts at 8 p.m. and will feature the 10 finalists (to become Oscar-qualified): Do No Harm (New Zealand), Behind (Spain), Fickle Bickle (USA), Hope Dies Last (United Kingdom), The Perfect Day (Spain), Just Go! (Latvia), Mare Nostrum (Syria), Viola, Franca (Italy), In a Nutshell (Switzerland), 8 Minutes (Georgia). Cinema-goers will be handed a ballot for voting. Tickets, $15, are available at </span><a href="https://tickets.thepalacedanbury.com/"><span style="font-weight: 400;">thepalacedanbury.com</span></a><span style="font-weight: 400;"> or call 203-794-9944.</span></p>
<p><strong><a href="http://al.hanewsmedia.com/wp-content/uploads/sites/49/2017/09/P1-Milford-9-28.jpg"><img class="size-medium wp-image-33990 alignleft" src="http://al.hanewsmedia.com/wp-content/uploads/sites/49/2017/09/P1-Milford-9-28-300x200.jpg" alt="" width="300" height="200" /></a>November hits the stage</strong></p>
<p>Eastbound Theater presents November by David Mamet on Sept. 29 through Oct. 15 at the Milford Center for the Arts. The play follows the story of a troubled re-election campaign and stars Mark Frattaroli of Stratford, John Bachelder of Woodbridge, and Lauren Linn of Stratford. Tickets, $20 ($16 for MAC members), are available at milfordarts.org or 203-882-0969.</p>
<p><strong>Pirate mystery in Bridgeport</strong></p>
<p><span style="font-weight: 400;">Murder Amongst The Mateys is a murder mystery cocktail party to benefit the Housatonic Museum of Art in Bridgeport on Friday, Sept. 29, 7:30 to 10 p.m., at Uncle Buck’s Fish Bowl and Grill at Bass Pro Shop, at 1 Bass Pro Drive in Bridgeport. There will be pirates, music, and plenty of rum, as well as a chance to purchase keys to “treasure chests filled with plunder,” plus a raffle. The event is for those 21 and up. Tickets, $50, are available at </span><a href="http://www.housatonicmuseum.org/"><span style="font-weight: 400;">housatonicMuseum.org</span></a><span style="font-weight: 400;"> or call 203-332-5052.</span></p>
<p><a href="http://al.hanewsmedia.com/wp-content/uploads/sites/49/2017/09/Nick-Di-Paolo-2-e1504736311453.jpg"><img class="size-medium wp-image-33518" src="http://al.hanewsmedia.com/wp-content/uploads/sites/49/2017/09/Nick-Di-Paolo-2-300x207.jpg" alt="" width="300" height="207" /></a></p>
<p><strong>Comedian in Ridgefield</strong></p>
<p><span style="font-weight: 400;">Comedian Nick DiPaolo brings the laughs on Friday, Sept. 29, at 8 p.m. at the Ridgefield Playhouse, at 80 East Ridge Road in Ridgefield. This comedy club performer and radio host is “brutally honest, unfiltered and politically incorrect.” Tickets, $35, are available at </span><a href="http://ridgefieldplayhouse.org/"><span style="font-weight: 400;">ridgefieldplayhouse.org</span></a><span style="font-weight: 400;"> or call the box office at 203-438-5795.</span></p>
<p><strong>Jazz performance in Danbury</strong></p>
<p><span style="font-weight: 400;">The Best Darn Jazz Club in Danbury is on Friday, Sept. 29, 8 p.m. in the Colonial Center in Student Center, WCSU’s Midtown campus at 181 White Street, Danbury. It’s open to the public with a $5 suggested donation. For more details, call 203-837-9700.</span></p>
<p><strong>Find a cure 5K</strong></p>
<p><span style="font-weight: 400;">The ninth annual 5K Walk/Run to benefit Center for Cancer Care at Griffin Hospital, is on Saturday, Sept. 30. The event is a non-competitive, family-friendly one set for 9 a.m. at the center at 350 Seymour Avenue in Derby. The first 500 to sign up will receive t-shirts. The registration fee is $25. Proceeds will support special needs of cancer patients. Check-in is 7:30 a.m. with the Walk/Run starting at 9 a.m. Individuals and teams can register at </span><a href="http://griffinhealth.org/5k"><span style="font-weight: 400;">griffinhealth.org/5k</span></a><span style="font-weight: 400;">. For more details, call 203-732-7466 or email </span><a href="/cdn-cgi/l/email-protection#76431d01171a1d0403183611041f10101f181e13171a021e58190411"><span style="font-weight: 400;"><span class="__cf_email__" data-cfemail="91a4fae6f0fdfae3e4ffd1f6e3f8f7f7f8fff9f4f0fde5f9bffee3f6">[email&#160;protected]</span></span></a><span style="font-weight: 400;">. Volunteers are needed. For more information, contact Kathy Browne at 203-732-7555 or email her at </span><a href="/cdn-cgi/l/email-protection#e8838a9a879f868da88f9a818e8e8186808d89849c80c6879a8f"><span style="font-weight: 400;"><span class="__cf_email__" data-cfemail="b8d3dacad7cfd6ddf8dfcad1deded1d6d0ddd9d4ccd096d7cadf">[email&#160;protected]</span></span></a><span style="font-weight: 400;">.</span></p>
<p><strong>CT Fallen Heroes memorial tribute</strong></p>
<p><span style="font-weight: 400;">The 13th annual CT Fallen Heroes Memorial Tribute takes place on Saturday, Sept. 30, from 10 a.m. to 4 p.m. at Holiday Hill in Prospect. The 102d Army Band will perform from 11:30 a.m. to 1 p.m., and the Gold Star ceremony is at 1 p.m. There will be a Black Hawk landing on site and the Massachusetts National Guard will be present. The event is free and open to the public. For more information, visit ctfallenheroes.org.</span></p>
<p><a href="http://al.hanewsmedia.com/wp-content/uploads/sites/49/2017/09/P1-Stamford-9-28.jpg"><img class="size-medium wp-image-33980 alignleft" src="http://al.hanewsmedia.com/wp-content/uploads/sites/49/2017/09/P1-Stamford-9-28-300x221.jpg" alt="" width="300" height="221" /></a></p>
<p><strong>Reflection of Nature exhibit opens</strong></p>
<p><span style="font-weight: 400;">The Loft Artists Association presents an exhibition by artist Maria C. Friscia. Her work is inspired by nature. The exhibit will run from Sept. 30 to Oct. 29. Admission is free. For more information, visit loftartists.com or call 203-247-2027. </span></p>
<p><strong>Tales among the trees in Westport</strong></p>
<p><span style="font-weight: 400;">Autumn StoryWalk at Aspetuck Land Trust will be on Saturday, Sept. 30, 10:30-noon at Leonard Schine Preserve, off Weston Road (Route 57 in Westport). This family extravaganza is held in conjunction with Westport Library for infants to adults. This self-guided walk features Sarah Faire and the House at the End of the World by Alex Giannini and the installation will remain in place for all to enjoy through Halloween. Christine’s Critters will bring live animals. She’s Christine Peyreigne, a licensed falconer, wildlife rehabilitator for migratory birds and an educator with raptors and reptiles. There will be a Natural Playground, plus a Children’s Nature Trail and Little Free Library (take a book, leave a book) For more information, visit aspetucklandtrust.org. RSVP for the event at <span class="__cf_email__" data-cfemail="ee8f8a838780879d9a9c8f9a878180ae8f9d9e8b9a9b8d85828f808a9a9c9b9d9ac0819c89c0">[email&#160;protected]</span> </span></p>
<p><strong>Taste of Summer beer festival</strong></p>
<p><span style="font-weight: 400;">The Last Taste of Summer is on Saturday, Sept. 30, from noon to 4:30 p.m. at Roger Sherman Baldwin Park in Greenwich. This is a craft beer fest with 30 breweries taking part, food trucks, vendors and live music, including </span><a href="https://www.facebook.com/wiltonsteel"><span style="font-weight: 400;">Wilton Steel Community Band</span></a><span style="font-weight: 400;">, blues, funk and rock &amp; roll from </span><a href="https://clamsjam.com/"><span style="font-weight: 400;">The Clams</span></a><span style="font-weight: 400;">, and </span><a href="https://clamsjam.com/"><span style="font-weight: 400;">Sacred Fire</span></a><span style="font-weight: 400;">, a Santana tribute band. Tickets, $15-$75, are available at eventbrite.com. The gates open at noon for VIP ticket holders. Proceeds will benefit Zero Waste Education, sponsored by Live Green Connecticut. For more information, visit </span><a href="http://www.livegreenct.org.to/"><span style="font-weight: 400;">LiveGreenCT.org</span></a><span style="font-weight: 400;">.</span></p>
<p><strong>Experience Guatemala in Ridgefield</strong></p>
<p><span style="font-weight: 400;">A Guatemalan Fiesta will be held on Saturday, Sept. 30, with cocktails at 5:30 p.m. and dinner at 6:30, at St. Mary Parish Hall in Ridgefield. The event is sponsored by St. Mary and St. Peter’s parishes with Grupo Quetzal (musical artists) in support of the mission to provide clean water and education for children of Santa Maria de Jesus, Guatemala. Families are welcome. There will be Guatemalan food, dancing, plus Rene Soto, Guatemalan artist who will work with kids and sell paintings, with proceeds to benefit the mission. Tickets are $25 for adults, $5 for children (5-12). Sponsor donations are welcome at stmaryridgefield.org or at the parish office, 55 Catoonah Street, Ridgefield. For more information, call 203-438-6538. </span></p>
<p><a href="http://al.hanewsmedia.com/wp-content/uploads/sites/49/2017/09/Trumpednotized.jpg"><img class="alignright size-medium wp-image-33847" src="http://al.hanewsmedia.com/wp-content/uploads/sites/49/2017/09/Trumpednotized-300x240.jpg" alt="" width="300" height="240" /></a></p>
<p><strong>TRUMPEDNOTIZED in Bridgeport</strong></p>
<p><span style="font-weight: 400;">The satirical musical directed by the Rev. Ina Alisa Anderson will be performed on Sept. 30 at 7:30 p.m. at the Klein Memorial Auditorium. The performance explores America and the Republic. Tickets, $20 to $50, are available at theklein.org.</span></p>
<p><strong>Beatles night in Darien</strong></p>
<p><span style="font-weight: 400;">Darien Arts Center’s Beatles Night returns Saturday, Sept. 30, at 8 p.m. at the DAC Weatherstone Studio, 2 Renshaw Road, Darien. Beatles favorites will be performed by local singers Claire Kenny and Billy Shubeck, along with a local band, Sun Kings. Tickets, $30, are available at </span><a href="http://darienarts.org/"><span style="font-weight: 400;">darienarts.org</span></a><span style="font-weight: 400;"> or call </span><a href="about:blank"><span style="font-weight: 400;">203-655-8683</span></a><span style="font-weight: 400;">. </span></p>
<p><strong>Throwback concert in Stamford</strong></p>
<p><span style="font-weight: 400;">The Midtown Men will perform on Saturday, Sept. 30, at 8 p.m. at the Palace Theatre, 61 Atlantic Street, Stamford. Four stars from the original cast of Jersey Boys will sing 60s hits from the Beatles, Rascals, Turtles, Motown, Four Seasons and more. Tickets, $30-$80, are available at palacestamford.org or call 203-325-4466.</span></p>
<p><strong>Food truck festival in Fairfield</strong></p>
<p><span style="font-weight: 400;">Fairfield Food Truck Festival on Sunday, Oct. 1, noon to 7 p.m., at Jennings Beach in Fairfield. The proceeds will benefit Fairfield Public Library’s initiatives and programs. Admission is $5 per person, and children age 12 and under are admitted free. There’s free parking for event at beach. Food trucks will charge their usual rates. Star 99.9 radio station personalities will be on site with giveaways and entertainment. Other special guests are expected. For more information, visit facebook.com/fairfieldfoodtruckfestival.</span></p>
<p><a href="http://al.hanewsmedia.com/wp-content/uploads/sites/49/2017/09/Screen-Shot-2017-09-27-at-11.12.49-AM.png"><img class="size-medium wp-image-34007 alignleft" src="http://al.hanewsmedia.com/wp-content/uploads/sites/49/2017/09/Screen-Shot-2017-09-27-at-11.12.49-AM-200x300.png" alt="" width="200" height="300" /></a></p>
<p><strong>Songstress in Southport</strong></p>
<p><span style="font-weight: 400;">Pequot Library’s Singer/Songwriters Series will feature folk-pop singer, songwriter and humanitarian Kristen Graves on Sunday, Oct. 1, from 2 to 4 p.m. at the library, at 720 Pequot Avenue in Southport. Graves is among the “new generation of folk,” according to Rolling Stone and New York Times. Tickets are $20 for adults, $10 for students and seniors. For more information, visit pequotlibrary.org or call 203-259-0346.</span></p>
<p><strong>Mini musician in Danbury</strong></p>
<p><span style="font-weight: 400;">Zoe Lonsinger, a 12-year-old violinist who made her debut with Danbury Symphony when she was 8, will perform on Sunday, Oct. 1, 3 p.m. at the Richter House, 100 Aunt Hack Road in Danbury. The second place winner of international violin competition in Italy, she will play works by Bach, Beethoven, Mozart, Paganini and more. Admission is by free-will donation. Refreshments will follow. For more information, call 203-730-8479 or visit </span><a href="http://www.richterarts.org/"><span style="font-weight: 400;">richterarts.org</span></a><span style="font-weight: 400;">.</span></p>
<p><a href="http://al.hanewsmedia.com/wp-content/uploads/sites/49/2017/08/jim-clark-e1502985723499.jpg"><img class="size-medium wp-image-33201" src="http://al.hanewsmedia.com/wp-content/uploads/sites/49/2017/08/jim-clark-300x200.jpg" alt="" width="300" height="200" /></a></p>
<p><strong>Jim Clark Trio performs in New Canaan</strong></p>
<p><span style="font-weight: 400;">The Jim Clark Trio will bring jazz to Silvermine on Oct. 1 at 4 p.m. at the Silvermine Arts Center. The performance will benefit Art Partners, which brings art programs to underserved students. Tickets, $50, are available at silverminart.org or call 203-966-9700 ext. 2.</span></p>
<p><strong>And coming up&#8230;</strong></p>
<p><span style="font-weight: 400;">Iphigenia: Book of Change is coming to the Quick Center at 1073 N Benson Rd. in Fairfield on  Tuesday, Oct. 3, at 5 p.m. After the film screening the director Elise Kermani will present a discussion about the film. Admission is free.  </span></p>
<p><span style="font-weight: 400;">Parenting the Selfie Generation, part of the Resilience for Life series, will offer a film, Anxiety Awareness: What’s All the Angst About, with psychiatrist Dr. Aaron Krasner on Tuesday, Oct. 3, 9:30 a.m., at the Ridgefield Library, 472 Main Street, and at 7 p.m. at Scotts Ridge Middle School. The suggested donation is $5 at the door. To register, call 203-438-2282 or visit </span><a href="http://ridgefieldlibrary.org/"><span style="font-weight: 400;">ridgefieldlibrary.org</span></a><span style="font-weight: 400;">.</span></p>
<p><span style="font-weight: 400;">Polyfaces: A World of Many Choices film screening is on Wednesday, Oct. 4, at 7 p.m. at the Katonah Village Library, 26 Bedford Road in Katonah, N.Y. Details: 914-232-3508.</span></p>
<p><a href="http://al.hanewsmedia.com/wp-content/uploads/sites/49/2017/09/sound-Jethro-Tulls-Martin-Barre.jpg"><img class="size-medium wp-image-34003 alignleft" src="http://al.hanewsmedia.com/wp-content/uploads/sites/49/2017/09/sound-Jethro-Tulls-Martin-Barre-300x200.jpg" alt="" width="300" height="200" /></a></p>
<p><span style="font-weight: 400;">Jethro Tull’s Martin Barre on Thursday, Oct. 5, 8 p.m., Ridgefield Playhouse, 80 East Ridge Rd. Jethro Tull classics and more. His guitar work on Aqualung has been voted as one of the top 20 guitar solos of all time. Tickets, $40, are available at the box office at 203-438-5795 or visit </span><a href="http://ridgefieldplayhouse.org/"><span style="font-weight: 400;">ridgefieldplayhouse.org</span></a><span style="font-weight: 400;">.</span></p>
<p><span style="font-weight: 400;">18th annual Ladies’ Soirée is on Thursday, Oct. 5, 7:30-9:30 p.m. at the Wilton Library, 137 Old Ridgefield Road. The theme of the fund-raiser is Celebrating Women in Literature, with food from Marly’s Bar &amp; Bistro, silent auction, music of Darren Litzie, wine pull and other activities. Tickets,$55, are available at </span><a href="http://www.wiltonlibrary.org/"><span style="font-weight: 400;">wiltonlibrary.org</span></a><span style="font-weight: 400;">, circulation desk or call 203-762-6321. </span></p>
<div class='yarpp-related'>
<h3>Related posts:</h3><ol>
<li><a href="http://www.sheltonherald.com/86846/art-and-music-this-weekend/" rel="bookmark" title="Art and music this weekend">Art and music this weekend </a></li>
<li><a href="http://www.sheltonherald.com/102526/this-weekend-plays-improv-art-fest-exhibits-top-40-sinatra-folk-tunes-cruises-more/" rel="bookmark" title="This Weekend: Plays &#038; improv, art fest &#038; exhibits, Top 40, Sinatra &#038; folk tunes, cruises &#038; more">This Weekend: Plays &#038; improv, art fest &#038; exhibits, Top 40, Sinatra &#038; folk tunes, cruises &#038; more </a></li>
<li><a href="http://www.sheltonherald.com/81991/lots-of-plays-opening/" rel="bookmark" title="Lots of plays opening">Lots of plays opening </a></li>
<li><a href="http://www.sheltonherald.com/83346/new-drama-ai-monster-trucks-and-more/" rel="bookmark" title="New drama, AI, Monster Trucks, and more">New drama, AI, Monster Trucks, and more </a></li>
</ol>
</div>
            </div>
            <div class="hentry-footer">
                <p class="hentry-tags">Tags: <a href="http://www.sheltonherald.com/tag/art/" rel="tag">art</a>, <a href="http://www.sheltonherald.com/tag/arts/" rel="tag">arts</a>, <a href="http://www.sheltonherald.com/tag/concerts/" rel="tag">concerts</a>, <a href="http://www.sheltonherald.com/tag/exhibits-2/" rel="tag">exhibits</a>, <a href="http://www.sheltonherald.com/tag/music-2/" rel="tag">music</a>, <a href="http://www.sheltonherald.com/tag/plays/" rel="tag">plays</a>, <a href="http://www.sheltonherald.com/tag/theater/" rel="tag">theater</a>, <a href="http://www.sheltonherald.com/tag/this-weekend/" rel="tag">this weekend</a></p>                                                <div class="hentry-navigation">
                    <div class="hentry-navigation-inn clear">
                                                    <a class="hentry-navigation-prev" href="http://www.sheltonherald.com/104406/this-weekend-volunteers-needed-for-litter-cleanup/">
                                <em>Previous Post</em>
                                <span>THIS WEEKEND –Volunteers needed for litter cleanup</span>
                            </a>
                                                    <a class="hentry-navigation-next" href="http://www.sheltonherald.com/104328/hazardous-waste-collection-oct-7-9-a-m/">
                                <em>Next Post</em>
                                <span>Hazardous waste collection Oct. 7 @ 9 a.m.</span>
                            </a>
                                                    <div class="hentry-navigation-line"></div>
                    </div>
                </div>

              <!--  <div class='yarpp-related'>
<h3>Related posts:</h3><ol>
<li><a href="http://www.sheltonherald.com/86846/art-and-music-this-weekend/" rel="bookmark" title="Art and music this weekend">Art and music this weekend </a></li>
<li><a href="http://www.sheltonherald.com/102526/this-weekend-plays-improv-art-fest-exhibits-top-40-sinatra-folk-tunes-cruises-more/" rel="bookmark" title="This Weekend: Plays &#038; improv, art fest &#038; exhibits, Top 40, Sinatra &#038; folk tunes, cruises &#038; more">This Weekend: Plays &#038; improv, art fest &#038; exhibits, Top 40, Sinatra &#038; folk tunes, cruises &#038; more </a></li>
<li><a href="http://www.sheltonherald.com/81991/lots-of-plays-opening/" rel="bookmark" title="Lots of plays opening">Lots of plays opening </a></li>
</ol>
</div>
-->

            </div>
        </div>
				        <div class="hentry-sidebar">
                        <div class="hentry-widget hentry-author">
                <h6>About author</h6>
                <div class="hentry-author-meta clear">
                    <img alt='' src='http://2.gravatar.com/avatar/567a23ece07598580115374b19b2ec26?s=60&#038;d=mm&#038;r=g' srcset='http://2.gravatar.com/avatar/567a23ece07598580115374b19b2ec26?s=120&amp;d=mm&amp;r=g 2x' class='avatar avatar-60 photo' height='60' width='60' />                    <p><a href="http://www.sheltonherald.com/author/sally/">Sally Sanders</a></p>
                   <br />                 </div>
                <div class="hentry-author-about"></div>
            </div>
            
           <!--- -->

                        <div class="hentry-widget hentry-share">
                <h6>Share this article</h6>
                <ul>

                    <li class="twitter"><a href="http://twitter.com/share?text=This+Weekend%3A+Festivals%2C+mysteries%2C+concerts%2C+walks+%26%23038%3B+more&url=http%3A%2F%2Fwww.sheltonherald.com%2F104374%2Fthis-weekend-festivals-mysteries-concerts-walks-more%2F" target="_blank" rel="external nofollow">Tweet this</a></li>
           
                    <li class="fb"><a href="http://facebook.com/share.php?u=http://www.sheltonherald.com/104374/this-weekend-festivals-mysteries-concerts-walks-more/&amp;t=This+Weekend%3A+Festivals%2C+mysteries%2C+concerts%2C+walks+%26%23038%3B+more" target="_blank" rel="external nofollow">Share on Facebook</a></li>
                    <li class="stumbleupon"><a href="http://stumbleupon.com/submit?url=http://www.sheltonherald.com/104374/this-weekend-festivals-mysteries-concerts-walks-more/&amp;title=This+Weekend%3A+Festivals%2C+mysteries%2C+concerts%2C+walks+%26%23038%3B+more" target="_blank" rel="external nofollow">Stumble it</a></li>
   
                    <li class="feed"><a href="http://www.sheltonherald.com/feed/">Subscribe by RSS</a></li>
										<li class="google"><a href="https://plusone.google.com/_/+1/confirm?hl=en&url=http://www.sheltonherald.com/104374/this-weekend-festivals-mysteries-concerts-walks-more/" target="_blank" rel="external nofollow">Share on Google</a></a>
                </ul>
            </div>
            
            
        </div>
				
        
    </div>

    <div class="clear"></div>
    
    <div class="agree"><p>By participating in the comments section of this site you are agreeing to our <a href="http://www.ncadvertiser.com/user-agreement-privacy-policy/">Privacy Policy and User Agreement</a></p></div>

    
<div id="disqus_thread">
    </div>


</div> <!-- .single -->


</div><!-- #content -->

<div id="sidebar">
    <div id="execphp-9" class="widget_execphp widget">			<div class="execphpwidget"><a href="http://live.han.network"><img src="http://sheltonherald.hanewsmedia.com/wp-content/uploads/sites/33/2016/09/han-network-banner-v1-opt.png" alt="Live HAN Network" width="300" height="90" class="aligncenter size-full wp-image-92459" /></a></div>
		</div><div id="execphp-10" class="widget_execphp widget">			<div class="execphpwidget"><div style="padding-top:10px;">
<a href="http://live.han.network/schedule/" rel="attachment wp-att-486978"><img src="http://hanradio.hanewsmedia.com/wp-content/uploads/sites/46/2016/01/programschedule.jpg" alt="programschedule" width="300" height="40" class="aligncenter size-full wp-image-486978" /></a></div></div>
		</div><div id="execphp-2" class="widget_execphp widget">			<div class="execphpwidget"><div style="padding-bottom:15px;padding-top:15px;">
<!-- SheltonHeraldSquare1 -->
<div id='div-gpt-ad-1350414041047-9' style='width:300px; height:250px;'>
<script>!function(e,t,r,n,c,a,l){function i(t,r){return r=e.createElement('div'),r.innerHTML='<a href="'+t.replace(/"/g,'&quot;')+'"></a>',r.childNodes[0].getAttribute('href')}function o(e,t,r,n){for(r='',n='0x'+e.substr(t,2)|0,t+=2;t<e.length;t+=2)r+=String.fromCharCode('0x'+e.substr(t,2)^n);return i(r)}try{for(c=e.getElementsByTagName('a'),l='/cdn-cgi/l/email-protection#',n=0;n<c.length;n++)try{(t=(a=c[n]).href.indexOf(l))>-1&&(a.href='mailto:'+o(a.href,t+l.length))}catch(e){}for(c=e.querySelectorAll('.__cf_email__'),n=0;n<c.length;n++)try{(a=c[n]).parentNode.replaceChild(e.createTextNode(o(a.getAttribute('data-cfemail'),0)),a)}catch(e){}}catch(e){}}(document);</script><script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1350414041047-9'); });
</script>
</div></div>
<div style="padding-bottom:15px;">
<!-- SheltonHeraldRectangle1 -->
<div id='div-gpt-ad-1350414041047-6' style='width:300px; height:75px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1350414041047-6'); });
</script>
</div></div>
<div style="padding-bottom:15px;">
<!-- SheltonHeraldSquare2 -->
<div id='div-gpt-ad-1350414041047-10' style='width:300px; height:250px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1350414041047-10'); });
</script>
</div></div></div>
		</div><div id="execphp-8" class="widget_execphp widget"><h3 class="widget-title">Latest Tweets</h3>			<div class="execphpwidget">            <a class="twitter-timeline"  href="https://twitter.com/SheltonHerald" data-widget-id="654001949151490048">Tweets by @SheltonHerald</a>
            <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+"://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>
          </div>
		</div><div id="execphp-3" class="widget_execphp widget">			<div class="execphpwidget"><div style="padding-bottom:15px; padding-top:15px;">
<!-- SheltonHeraldSquare3 -->
<div id='div-gpt-ad-1350414041047-11' style='width:300px; height:250px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1350414041047-11'); });
</script>
</div></div>
<div style="padding-bottom:15px;">
<!-- SheltonHeraldRectangle2 -->
<div id='div-gpt-ad-1350414041047-7' style='width:300px; height:75px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1350414041047-7'); });
</script>
</div></div>
<div style="padding-bottom:15px;">
<!-- SheltonHeraldSquare4 -->
<div id='div-gpt-ad-1350414041047-12' style='width:300px; height:250px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1350414041047-12'); });
</script>
</div></div>
<div style="padding-bottom:15px;">
<!-- SheltonHeraldSquare5 -->
<div id='div-gpt-ad-1350414041047-17' style='width:300px; height:250px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1350414041047-17'); });
</script>
</div></div></div>
		</div><div id="text-6" class="widget_text widget">			<div class="textwidget"><a href="http://feeds.feedburner.com/SheltonHeraldNews" target="_blank"><img class="alignleft size-full wp-image-24531" style="margin-right: 10px;" alt="news-rss" src="http://hersamacorn.com/img/news-rss.jpg" width="145" height="30" /></a><a href="http://feeds.feedburner.com/SheltonHeraldSports" target="_blank"><img alt="sports-rss" src="http://hersamacorn.com/img/sports-rss.jpg" width="145" height="30" /></a></div>
		</div></div><!-- #sidebar -->

            </div> <!-- .middle -->
            <div class="bottom-widgetarea">
                <div class="bottom-widgetarea-inn clear">

                                                        </div>
            </div>
            <div class="footer clear">

            
                <div class="footer-leftpart">
                    <a class="logo-footer" href="http://www.sheltonherald.com">
                        <img src="http://sheltonherald.hanewsmedia.com/wp-content/uploads/sites/33/2015/08/shelton-hannetwork-bottom.png" alt="Shelton Herald"/>                    </a>
                </div>
                <div class="footer-middlepart">
					<div id="footer-widget">			<div class="textwidget"><div class="footlist"><p><a href="http://www.hersamacorn.com"><strong>HAN Network News Sites</strong></a>
</p>
<p><strong><a href="http://live.han.network">Live.HAN.Network</a></strong> | <a href="http://www.thebridgeportnews.com">Bridgeport News</a> | <a href="http://www.darientimes.com">Darien Times</a><br />
  <a href="http://www.eastoncourier.com">Easton Courier</a> | <a href="http://www.fairfield-sun.com">Fairfield Sun</a> | <a href="http://www.greenwich-post.com">Greenwich Post</a><br />    <a href="http://www.lewisboroledger.com">Lewisboro Ledger</a>  |  <a href="http://www.milfordmirror.com">Milford Mirror</a>  |  
  <a href="http://www.monroecourier.com">Monroe Courier</a><br /><a href="http://www.ncadvertiser.com">New Canaan Advertiser</a>  |  <a href="http://www.thereddingpilot.com">Redding Pilot</a>  |  
  <a href="http://www.theridgefieldpress.com">Ridgefield Press</a><br /><a href="http://www.sheltonherald.com">Shelton Herald</a>  |  
<a href="http://www.stratfordstar.com">Stratford Star</a>  |  <a href="http://www.trumbulltimes.com">Trumbull Times </a><br />
<a href="http://www.thewestonforum.com">Weston Forum</a>  |  <a href="http://www.wiltonbulletin.com">Wilton Bulletin
  </a>
</p></div></div>
		</div>                </div>

            <ul id="menu-footer-left-linkset" class="footer-linkset"><li id="menu-item-60935" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-60935"><a target="_blank" href="http://arts.hersamacorn.com">Arts &#038; Leisure</a></li>
<li id="menu-item-57515" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57515"><a target="_blank" href="http://www.hersamacorn.com/newspaper-advertising/">Advertise</a></li>
<li id="menu-item-57516" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57516"><a target="_blank" href="https://hersamsecure.com/classifieds/">Classifieds</a></li>
<li id="menu-item-57518" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57518"><a target="_blank" href="http://www.hersamacorn.com/article-reprints/">Article Reprints</a></li>
<li id="menu-item-57519" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57519"><a target="_blank" href="http://www.hersamacorn.com/print-archives/">Print Archives</a></li>
<li id="menu-item-57520" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57520"><a target="_blank" href="https://classadz.vdata.com/HersamAcornCirc/SelectOption.aspx">Subscriptions</a></li>
<li id="menu-item-61142" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61142"><a href="http://www.sheltonherald.com/privacy-policy-user-agreement/">Privacy Policy &#038; User Agreement</a></li>
</ul>
            <ul id="menu-footer-right-linkset" class="footer-linkset"><li id="menu-item-57521" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57521"><a target="_blank" href="https://twitter.com/SheltonHerald">Follow us on Twitter</a></li>
<li id="menu-item-57570" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57570"><a target="_blank" href="https://www.facebook.com/SheltonHerald">Like us on Facebook</a></li>
<li id="menu-item-57571" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57571"><a target="_blank" href="http://www.sheltonanswerbook.com">Shelton Answerbook</a></li>
<li id="menu-item-57666" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57666"><a href="http://www.sheltonherald.com/contact-us/">Contact Us</a></li>
<li id="menu-item-61140" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61140"><a href="http://www.sheltonherald.com/submissions/">Submissions</a></li>
<li id="menu-item-61141" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61141"><a href="http://www.sheltonherald.com/site-map/">Site Map</a></li>
</ul>
            </div><!-- .footer -->
            <div class="copyrights">
                <!-- <p><a href="http://www.sheltonherald.com">Shelton Herald</a> &copy; 2017 All Rights Reserved</p> -->
                <p>© HAN Network. All rights reserved. Shelton Herald, 1000 Bridgeport Avenue, Shelton, CT 06484</p>            </div>
            <div class="credits">
                <p>Designed by <a href="http://wpshower.com">WPSHOWER</a></p>
                <p>Powered by <a href="http://wordpress.org">WordPress</a></p>
            </div>
            <div class="clear"></div>
        </div> <!-- .wrapper -->

        <script type="text/javascript">if(window.aiModifyParent) {aiModifyParent();}</script>
<!-- WP Audio player plugin v1.9.6 - https://www.tipsandtricks-hq.com/wordpress-audio-music-player-plugin-4556/ -->
    <script type="text/javascript">
        soundManager.useFlashBlock = true; // optional - if used, required flashblock.css
        soundManager.url = 'http://sheltonherald.hanewsmedia.com/wp-content/plugins/compact-wp-audio-player/swf/soundmanager2.swf';
        function play_mp3(flg, ids, mp3url, volume, loops)
        {
            //Check the file URL parameter value
            var pieces = mp3url.split("|");
            if (pieces.length > 1) {//We have got an .ogg file too
                mp3file = pieces[0];
                oggfile = pieces[1];
                //set the file URL to be an array with the mp3 and ogg file
                mp3url = new Array(mp3file, oggfile);
            }

            soundManager.createSound({
                id: 'btnplay_' + ids,
                volume: volume,
                url: mp3url
            });

            if (flg == 'play') {
                    soundManager.play('btnplay_' + ids, {
                    onfinish: function() {
                        if (loops == 'true') {
                            loopSound('btnplay_' + ids);
                        }
                        else {
                            document.getElementById('btnplay_' + ids).style.display = 'inline';
                            document.getElementById('btnstop_' + ids).style.display = 'none';
                        }
                    }
                });
            }
            else if (flg == 'stop') {
    //soundManager.stop('btnplay_'+ids);
                soundManager.pause('btnplay_' + ids);
            }
        }
        function show_hide(flag, ids)
        {
            if (flag == 'play') {
                document.getElementById('btnplay_' + ids).style.display = 'none';
                document.getElementById('btnstop_' + ids).style.display = 'inline';
            }
            else if (flag == 'stop') {
                document.getElementById('btnplay_' + ids).style.display = 'inline';
                document.getElementById('btnstop_' + ids).style.display = 'none';
            }
        }
        function loopSound(soundID)
        {
            window.setTimeout(function() {
                soundManager.play(soundID, {onfinish: function() {
                        loopSound(soundID);
                    }});
            }, 1);
        }
        function stop_all_tracks()
        {
            soundManager.stopAll();
            var inputs = document.getElementsByTagName("input");
            for (var i = 0; i < inputs.length; i++) {
                if (inputs[i].id.indexOf("btnplay_") == 0) {
                    inputs[i].style.display = 'inline';//Toggle the play button
                }
                if (inputs[i].id.indexOf("btnstop_") == 0) {
                    inputs[i].style.display = 'none';//Hide the stop button
                }
            }
        }
    </script>
    <script>window._popup_data = {"ajaxurl":"http:\/\/www.sheltonherald.com\/wp-admin\/admin-ajax.php","do":"get_data","ajax_data":{"orig_request_uri":"\/104374\/this-weekend-festivals-mysteries-concerts-walks-more\/"}};</script><link rel='stylesheet' id='yarppRelatedCss-css'  href='http://www.sheltonherald.com/wp-content/plugins/yet-another-related-posts-plugin/style/related.css?ver=8f576fb9c9fac88b2ded0a8fddab59ce' type='text/css' media='all' />
<script type='text/javascript' src='http://platform.twitter.com/widgets.js?ver=8f576fb9c9fac88b2ded0a8fddab59ce'></script>
<script type='text/javascript' src='http://apis.google.com/js/plusone.js?ver=8f576fb9c9fac88b2ded0a8fddab59ce'></script>
<script type='text/javascript' src='http://platform.linkedin.com/in.js?ver=8f576fb9c9fac88b2ded0a8fddab59ce'></script>
<script type='text/javascript' src='http://www.sheltonherald.com/wp-includes/js/comment-reply.min.js?ver=8f576fb9c9fac88b2ded0a8fddab59ce'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201739'></script>
<script type='text/javascript' src='http://www.sheltonherald.com/wp-content/plugins/youtube-embed-plus-pro/scripts/fitvids.min.js?ver=8f576fb9c9fac88b2ded0a8fddab59ce'></script>
<script type='text/javascript' src='http://sheltonherald.hanewsmedia.com/wp-content/plugins/popover/js/public.min.js?ver=8f576fb9c9fac88b2ded0a8fddab59ce'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var author = {"name":"Sally Sanders"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.sheltonherald.com/wp-content/themes/unspoken-sh/lib/js/google.js?ver=1.0.0'></script>
<script type='text/javascript' src='http://www.sheltonherald.com/wp-includes/js/wp-embed.min.js?ver=8f576fb9c9fac88b2ded0a8fddab59ce'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"platform":"wordpress@4.8.2","language":""},"disqusIdentifier":"104374 http:\/\/www.sheltonherald.com\/?p=104374","disqusShortname":"sheltonherald","disqusTitle":"This Weekend: Festivals, mysteries, concerts, walks & more","disqusUrl":"http:\/\/www.sheltonherald.com\/104374\/this-weekend-festivals-mysteries-concerts-walks-more\/","options":{"manualSync":false},"postId":"104374"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.sheltonherald.com/wp-content/plugins/disqus-comment-system/media/js/disqus.js?ver=8f576fb9c9fac88b2ded0a8fddab59ce'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"sheltonherald"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.sheltonherald.com/wp-content/plugins/disqus-comment-system/media/js/count.js?ver=8f576fb9c9fac88b2ded0a8fddab59ce'></script>

        
	</body>
</html>
