<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN" "http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" dir="ltr" xml:lang="en-US">
    <head>
        <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
        <title>
           Troop 28     
</title>
        <link rel="profile" href="http://gmpg.org/xfn/11" />
        <link rel="shortcut icon" href="http://sheltonherald.hanewsmedia.com/wp-content/uploads/sites/33/2015/09/SH-favicon.png" type="image/x-icon" />		<link rel="stylesheet" href="http://www.sheltonherald.com/wp-content/themes/unspoken-sh/style.css" type="text/css" media="all" />
		<link rel="stylesheet" href="http://www.sheltonherald.com/wp-content/themes/unspoken-sh/lib/js/fancybox/jquery.fancybox-1.3.4.css" type="text/css" media="all" />
        <link rel="pingback" href="http://www.sheltonherald.com/xmlrpc.php" />
        <link rel="alternate" type="text/xml" title="RSS .92" href="http://www.sheltonherald.com/feed/rss/"/>
        <link rel="alternate" type="application/atom+xml" title="Atom 0.3" href="http://www.sheltonherald.com/feed/atom/" />
		<!--[if lt IE 8]><link rel="stylesheet" href="http://www.sheltonherald.com/wp-content/themes/unspoken-sh/ie.css" type="text/css" media="all" /><![endif]-->

        
        
        
<!-- This site is optimized with the Yoast SEO Premium plugin v2.3.4 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="On Saturday April 22 Boy Scout Troop 28 removed garbage from an open space area located near the Shelton Lakes Path in Shelton. At first the scouts found v"/>
<link rel="canonical" href="http://www.sheltonherald.com/99787/troop-28-cleans-up-for-earth-day-clean-sweep/" />
<link rel="publisher" href="https://plus.google.com/+SheltonHerald/about"/>
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Troop 28" />
<meta property="og:description" content="On Saturday April 22 Boy Scout Troop 28 removed garbage from an open space area located near the Shelton Lakes Path in Shelton. At first the scouts found v" />
<meta property="og:url" content="http://www.sheltonherald.com/99787/troop-28-cleans-up-for-earth-day-clean-sweep/" />
<meta property="og:site_name" content="Shelton Herald" />
<meta property="article:publisher" content="https://www.facebook.com/SheltonHerald" />
<meta property="article:section" content="Community" />
<meta property="article:published_time" content="2017-04-24T16:06:03+00:00" />
<meta property="og:image" content="http://sheltonherald.hanewsmedia.com/wp-content/uploads/sites/33/2015/05/SH-icon-600x600.png" />
<meta name="twitter:card" content="summary_large_image"/>
<meta name="twitter:description" content="On Saturday April 22 Boy Scout Troop 28 removed garbage from an open space area located near the Shelton Lakes Path in Shelton. At first the scouts found v"/>
<meta name="twitter:title" content="Troop 28"/>
<meta name="twitter:site" content="@sheltonherald"/>
<meta name="twitter:domain" content="Shelton Herald"/>
<meta name="twitter:image:src" content="http://sheltonherald.hanewsmedia.com/wp-content/uploads/sites/33/2015/05/SH-icon-600x600.png"/>
<meta name="twitter:creator" content="@sheltonherald"/>
<!-- / Yoast SEO Premium plugin. -->

<link rel='dns-prefetch' href='//sheltonherald.hanewsmedia.com' />
<link rel='dns-prefetch' href='//platform.twitter.com' />
<link rel='dns-prefetch' href='//apis.google.com' />
<link rel='dns-prefetch' href='//platform.linkedin.com' />
<link rel='dns-prefetch' href='//www.sheltonherald.com' />
<link rel='dns-prefetch' href='//p.jwpcdn.com' />
<link rel='dns-prefetch' href='//cdn.datatables.net' />
<link rel='dns-prefetch' href='//cdn.rawgit.com' />
<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//www.google.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Shelton Herald &raquo; Feed" href="http://www.sheltonherald.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Shelton Herald &raquo; Comments Feed" href="http://www.sheltonherald.com/comments/feed/" />
<link rel="alternate" type="text/calendar" title="Shelton Herald &raquo; iCal Feed" href="http://www.sheltonherald.com/events/?ical=1" />
<link rel="alternate" type="application/rss+xml" title="Shelton Herald &raquo; Troop 28 cleans up for Earth Day, Clean Sweep Comments Feed" href="http://www.sheltonherald.com/99787/troop-28-cleans-up-for-earth-day-clean-sweep/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.sheltonherald.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=acdaae8ca8ba9e4909e785333059eb2c"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='yarppWidgetCss-css'  href='http://www.sheltonherald.com/wp-content/plugins/yet-another-related-posts-plugin/style/widget.css?ver=acdaae8ca8ba9e4909e785333059eb2c' type='text/css' media='all' />
<link rel='stylesheet' id='scap.flashblock-css'  href='http://sheltonherald.hanewsmedia.com/wp-content/plugins/compact-wp-audio-player/css/flashblock.css?ver=acdaae8ca8ba9e4909e785333059eb2c' type='text/css' media='all' />
<link rel='stylesheet' id='scap.player-css'  href='http://sheltonherald.hanewsmedia.com/wp-content/plugins/compact-wp-audio-player/css/player.css?ver=acdaae8ca8ba9e4909e785333059eb2c' type='text/css' media='all' />
<link rel='stylesheet' id='tfg_style-css'  href='http://www.sheltonherald.com/wp-content/plugins/twitter-facebook-google-plusone-share/tfg_style.css?ver=acdaae8ca8ba9e4909e785333059eb2c' type='text/css' media='all' />
<link rel='stylesheet' id='advpsStyleSheet-css'  href='http://sheltonherald.hanewsmedia.com/wp-content/plugins/advanced-post-slider/advps-style.css?ver=acdaae8ca8ba9e4909e785333059eb2c' type='text/css' media='all' />
<link rel='stylesheet' id='jquery-datatables-css'  href='//cdn.datatables.net/1.10.12/css/jquery.dataTables.min.css?ver=acdaae8ca8ba9e4909e785333059eb2c' type='text/css' media='all' />
<link rel='stylesheet' id='datatables-buttons-css'  href='//cdn.datatables.net/buttons/1.2.1/css/buttons.dataTables.min.css?ver=acdaae8ca8ba9e4909e785333059eb2c' type='text/css' media='all' />
<link rel='stylesheet' id='datatables-select-css'  href='//cdn.datatables.net/select/1.2.0/css/select.dataTables.min.css?ver=acdaae8ca8ba9e4909e785333059eb2c' type='text/css' media='all' />
<link rel='stylesheet' id='datatables-fixedheader-css'  href='//cdn.datatables.net/fixedheader/3.1.2/css/fixedHeader.dataTables.min.css?ver=acdaae8ca8ba9e4909e785333059eb2c' type='text/css' media='all' />
<link rel='stylesheet' id='datatables-fixedcolumns-css'  href='//cdn.datatables.net/fixedcolumns/3.2.2/css/fixedColumns.dataTables.min.css?ver=acdaae8ca8ba9e4909e785333059eb2c' type='text/css' media='all' />
<link rel='stylesheet' id='datatables-responsive-css'  href='//cdn.datatables.net/responsive/2.1.0/css/responsive.dataTables.min.css?ver=acdaae8ca8ba9e4909e785333059eb2c' type='text/css' media='all' />
<link rel='stylesheet' id='ce_responsive-css'  href='http://www.sheltonherald.com/wp-content/plugins/simple-embed-code/css/video-container.css?ver=acdaae8ca8ba9e4909e785333059eb2c' type='text/css' media='all' />
<link rel='stylesheet' id='cpsh-shortcodes-css'  href='http://sheltonherald.hanewsmedia.com/wp-content/plugins/column-shortcodes/assets/css/shortcodes.css?ver=0.6.9' type='text/css' media='all' />
<link rel='stylesheet' id='__EPYT__style-css'  href='http://www.sheltonherald.com/wp-content/plugins/youtube-embed-plus-pro/styles/ytprefs.min.css?ver=acdaae8ca8ba9e4909e785333059eb2c' type='text/css' media='all' />
<style id='__EPYT__style-inline-css' type='text/css'>

                .epyt-gallery-thumb {
                        width: 33.333%;
                }
                
</style>
<link rel='stylesheet' id='__disptype__-css'  href='http://www.sheltonherald.com/wp-content/plugins/youtube-embed-plus-pro/scripts/lity.min.css?ver=acdaae8ca8ba9e4909e785333059eb2c' type='text/css' media='all' />
<link rel='stylesheet' id='wpmu-animate-min-css-css'  href='http://sheltonherald.hanewsmedia.com/wp-content/plugins/popover/css/animate.min.css?ver=acdaae8ca8ba9e4909e785333059eb2c' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://www.sheltonherald.com/wp-content/plugins/jetpack/css/jetpack.css?ver=4.8.2' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var tribe_events_linked_posts = {"post_types":{"tribe_venue":"venue","tribe_organizer":"organizer"}};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.sheltonherald.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://www.sheltonherald.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://sheltonherald.hanewsmedia.com/wp-content/plugins/compact-wp-audio-player/js/soundmanager2-nodebug-jsmin.js?ver=acdaae8ca8ba9e4909e785333059eb2c'></script>
<script type='text/javascript' src='http://www.sheltonherald.com/wp-content/themes/unspoken-sh/lib/js/jcarousellite_1.0.1_mod.js?ver=acdaae8ca8ba9e4909e785333059eb2c'></script>
<script type='text/javascript' src='http://www.sheltonherald.com/wp-content/themes/unspoken-sh/lib/js/fancybox/jquery.fancybox-1.3.4.pack.js?ver=acdaae8ca8ba9e4909e785333059eb2c'></script>
<script type='text/javascript' src='http://www.sheltonherald.com/wp-content/themes/unspoken-sh/lib/js/scripts.js?ver=acdaae8ca8ba9e4909e785333059eb2c'></script>
<script type='text/javascript' src='http://www.sheltonherald.com/wp-content/themes/unspoken-sh/lib/js/jquery.infinitescroll.init.js?ver=acdaae8ca8ba9e4909e785333059eb2c'></script>
<script type='text/javascript' src='http://p.jwpcdn.com/6/12/jwplayer.js?ver=acdaae8ca8ba9e4909e785333059eb2c'></script>
<script type='text/javascript' src='http://sheltonherald.hanewsmedia.com/wp-content/plugins/advanced-post-slider/js/advps.frnt.script.js?ver=acdaae8ca8ba9e4909e785333059eb2c'></script>
<script type='text/javascript' src='http://sheltonherald.hanewsmedia.com/wp-content/plugins/advanced-post-slider/bxslider/jquery.bxslider.min.js?ver=acdaae8ca8ba9e4909e785333059eb2c'></script>
<script type='text/javascript' src='//cdn.datatables.net/1.10.12/js/jquery.dataTables.min.js?ver=acdaae8ca8ba9e4909e785333059eb2c'></script>
<script type='text/javascript' src='//cdn.datatables.net/buttons/1.2.1/js/dataTables.buttons.min.js?ver=acdaae8ca8ba9e4909e785333059eb2c'></script>
<script type='text/javascript' src='//cdn.datatables.net/buttons/1.2.1/js/buttons.colVis.min.js?ver=acdaae8ca8ba9e4909e785333059eb2c'></script>
<script type='text/javascript' src='//cdn.datatables.net/buttons/1.2.1/js/buttons.print.min.js?ver=acdaae8ca8ba9e4909e785333059eb2c'></script>
<script type='text/javascript' src='//cdn.rawgit.com/bpampuch/pdfmake/0.1.18/build/pdfmake.min.js?ver=acdaae8ca8ba9e4909e785333059eb2c'></script>
<script type='text/javascript' src='//cdn.rawgit.com/bpampuch/pdfmake/0.1.18/build/vfs_fonts.js?ver=acdaae8ca8ba9e4909e785333059eb2c'></script>
<script type='text/javascript' src='//cdnjs.cloudflare.com/ajax/libs/jszip/2.5.0/jszip.min.js?ver=acdaae8ca8ba9e4909e785333059eb2c'></script>
<script type='text/javascript' src='//cdn.datatables.net/buttons/1.2.1/js/buttons.html5.min.js?ver=acdaae8ca8ba9e4909e785333059eb2c'></script>
<script type='text/javascript' src='//cdn.datatables.net/select/1.2.0/js/dataTables.select.min.js?ver=acdaae8ca8ba9e4909e785333059eb2c'></script>
<script type='text/javascript' src='//cdn.datatables.net/fixedheader/3.1.2/js/dataTables.fixedHeader.min.js?ver=acdaae8ca8ba9e4909e785333059eb2c'></script>
<script type='text/javascript' src='//cdn.datatables.net/fixedcolumns/3.2.2/js/dataTables.fixedColumns.min.js?ver=acdaae8ca8ba9e4909e785333059eb2c'></script>
<script type='text/javascript' src='//cdn.datatables.net/responsive/2.1.0/js/dataTables.responsive.min.js?ver=acdaae8ca8ba9e4909e785333059eb2c'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var igsv_plugin_vars = {"lang_dir":"http:\/\/www.sheltonherald.com\/wp-content\/plugins\/inline-google-spreadsheet-viewer\/languages","datatables_classes":".igsv-table:not(.no-datatables)","datatables_defaults_object":{"dom":"B<'clear'>lfrtip","buttons":[]}};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.sheltonherald.com/wp-content/plugins/inline-google-spreadsheet-viewer/igsv-datatables.js?ver=acdaae8ca8ba9e4909e785333059eb2c'></script>
<script type='text/javascript' src='//www.google.com/jsapi?ver=acdaae8ca8ba9e4909e785333059eb2c'></script>
<script type='text/javascript' src='http://www.sheltonherald.com/wp-content/plugins/inline-google-spreadsheet-viewer/igsv-gvizcharts.js?ver=acdaae8ca8ba9e4909e785333059eb2c'></script>
<script type='text/javascript' src='http://www.sheltonherald.com/wp-content/plugins/advanced-iframe/js/ai.js?ver=791455'></script>
<script type='text/javascript' src='http://www.sheltonherald.com/wp-content/plugins/youtube-embed-plus-pro/scripts/lity.min.js?ver=acdaae8ca8ba9e4909e785333059eb2c'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _EPYT_ = {"ajaxurl":"http:\/\/www.sheltonherald.com\/wp-admin\/admin-ajax.php","security":"9686946605","gallery_scrolloffset":"20","eppathtoscripts":"http:\/\/www.sheltonherald.com\/wp-content\/plugins\/youtube-embed-plus-pro\/scripts\/","epresponsiveselector":"[\"iframe[src*='youtube.com']\",\"iframe[src*='youtube-nocookie.com']\",\"iframe[data-ep-src*='youtube.com']\",\"iframe[data-ep-src*='youtube-nocookie.com']\",\"iframe[data-ep-gallerysrc*='youtube.com']\"]","epdovol":"1","version":"11.7.1","evselector":"iframe.__youtube_prefs__[src], iframe[src*=\"youtube.com\/embed\/\"], iframe[src*=\"youtube-nocookie.com\/embed\/\"]","stopMobileBuffer":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.sheltonherald.com/wp-content/plugins/youtube-embed-plus-pro/scripts/ytprefs.min.js?ver=acdaae8ca8ba9e4909e785333059eb2c'></script>
<link rel='https://api.w.org/' href='http://www.sheltonherald.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.sheltonherald.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.sheltonherald.com/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='http://bit.ly/2ptDEfB' />
<link rel="alternate" type="application/json+oembed" href="http://www.sheltonherald.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.sheltonherald.com%2F99787%2Ftroop-28-cleans-up-for-earth-day-clean-sweep%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.sheltonherald.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.sheltonherald.com%2F99787%2Ftroop-28-cleans-up-for-earth-day-clean-sweep%2F&#038;format=xml" />
<script type="text/javascript">jwplayer.defaults = { "ph": 2 };</script><link rel="alternate" type="application/rss+xml" title="Shelton Herald GeoRSS-Feed" href="http://sheltonherald.hanewsmedia.com/wp-content/plugins/leaflet-maps-marker/leaflet-georss.php?layer=all" />
<a href="https://plus.google.com/+SheltonHerald" rel="publisher" />

<script type='text/javascript'>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
var gads = document.createElement('script');
gads.async = true;
gads.type = 'text/javascript';
var useSSL = 'https:' == document.location.protocol;
gads.src = (useSSL ? 'https:' : 'http:') + 
'//www.googletagservices.com/tag/js/gpt.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(gads, node);
})();
</script>

<script type='text/javascript'>
googletag.cmd.push(function() {
googletag.defineSlot('/18392239/SheltonHerald-KristineLilly-Rectangle', [300, 75], 'div-gpt-ad-1350414041047-0').addService(googletag.pubads());
googletag.defineSlot('/18392239/SheltonHerald-KristineLilly-Square1', [300, 250], 'div-gpt-ad-1350414041047-1').addService(googletag.pubads());
googletag.defineSlot('/18392239/SheltonHerald-KristineLilly-Square2', [300, 250], 'div-gpt-ad-1350414041047-2').addService(googletag.pubads());
googletag.defineSlot('/18392239/SheltonHerald-KristineLilly-Square3', [300, 250], 'div-gpt-ad-1350414041047-3').addService(googletag.pubads());
googletag.defineSlot('/18392239/SheltonHeraldEarLeft', [180, 90], 'div-gpt-ad-1350414041047-4').addService(googletag.pubads());
googletag.defineSlot('/18392239/SheltonHeraldEarRight', [180, 90], 'div-gpt-ad-1350414041047-5').addService(googletag.pubads());
googletag.defineSlot('/18392239/SheltonHeraldRectangle1', [300, 75], 'div-gpt-ad-1350414041047-6').addService(googletag.pubads());
googletag.defineSlot('/18392239/SheltonHeraldRectangle2', [300, 75], 'div-gpt-ad-1350414041047-7').addService(googletag.pubads());
googletag.defineSlot('/18392239/SheltonHeraldRectangle3', [300, 75], 'div-gpt-ad-1350414041047-8').addService(googletag.pubads());
googletag.defineSlot('/18392239/SheltonHeraldSquare1', [300, 250], 'div-gpt-ad-1350414041047-9').addService(googletag.pubads());
googletag.defineSlot('/18392239/SheltonHeraldSquare2', [300, 250], 'div-gpt-ad-1350414041047-10').addService(googletag.pubads());
googletag.defineSlot('/18392239/SheltonHeraldSquare3', [300, 250], 'div-gpt-ad-1350414041047-11').addService(googletag.pubads());
googletag.defineSlot('/18392239/SheltonHeraldSquare4', [300, 250], 'div-gpt-ad-1350414041047-12').addService(googletag.pubads());
googletag.defineSlot('/18392239/SheltonHeraldNavBar', [728, 90], 'div-gpt-ad-1350414041047-13').addService(googletag.pubads());
googletag.defineSlot('/18392239/SheltonHeraldLocalYokelSquare', [300, 250], 'div-gpt-ad-1350414041047-14').addService(googletag.pubads());
googletag.defineSlot('/18392239/SheltonHeraldSplashAd', [600, 240], 'div-gpt-ad-1350414041047-15').addService(googletag.pubads());
googletag.defineSlot('/18392239/SheltonHeraldLocalYokelSpecial', [300, 250], 'div-gpt-ad-1350414041047-16').addService(googletag.pubads());
googletag.defineSlot('/18392239/SheltonHeraldSquare5', [300, 250], 'div-gpt-ad-1350414041047-17').addService(googletag.pubads());
googletag.defineSlot('/18392239/SheltonHeraldLargeSplash', [740, 510], 'div-gpt-ad-1448031815686-19').addService(googletag.pubads());

googletag.pubads().enableSingleRequest();
googletag.enableServices();
});
</script>

 <!-- Load Facebook SDK for JavaScript -->
  <div id="fb-root"></div>
  <script>(function(d, s, id) {
    var js, fjs = d.getElementsByTagName(s)[0];
    if (d.getElementById(id)) return;
    js = d.createElement(s); js.id = id;
    js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.6";
    fjs.parentNode.insertBefore(js, fjs);
  }(document, 'script', 'facebook-jssdk'));</script>

<style type="text/css">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</style>  

   
	</head>
	<body class="post-template-default single single-post postid-99787 single-format-standard tribe-bar-is-disabled">

        <div class="wrapper">
        
                        <div class="top-content-adplace">
                    <div id="execphp-5" class="widget_execphp">			<div class="execphpwidget"><!-- SheltonHeraldNavBar -->
<div id='div-gpt-ad-1350414041047-13' style='width:728px; height:90px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1350414041047-13'); });
</script>
</div></div>
		</div>                </div>
                                
            <div class="header">
                <div class="header-meta">

                    <div id="top-menu" class="menu-top-menu-container"><ul id="menu-top-menu" class="header-menu clear"><li id="menu-item-61047" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-61047"><a href="http://sheltonherald.com">Home</a></li>
<li id="menu-item-57574" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57574"><a target="_blank" href="https://classadz.vdata.com/HersamAcornCirc/SelectOption.aspx">Subscribe</a></li>
<li id="menu-item-61117" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-61117"><a target="_blank" href="http://sheltonherald.ct.newsmemory.com/">E-Edition</a></li>
<li id="menu-item-57577" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57577"><a target="_blank" href="http://sheltonherald.ct.newsmemory.com/marketplace.php">Marketplace</a></li>
<li id="menu-item-61120" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-61120"><a href="http://vermontnews-guide.com/">Visit Vermont</a></li>
<li id="menu-item-61127" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61127"><a href="http://www.sheltonherald.com/sign-up-for-email-alerts/">Sign up for Email Alerts</a></li>
<li id="menu-item-57575" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children parent menu-item-57575"><a href="http://#">Print Edition</a>
<ul class="sub-menu">
	<li id="menu-item-57653" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57653"><a href="http://www.sheltonherald.com/shelton-newsstands/">Shelton Newsstands</a></li>
	<li id="menu-item-57576" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57576"><a target="_blank" href="https://classadz.vdata.com/HersamAcornCirc/SelectOption.aspx">Delivery Problems</a></li>
</ul>
</li>
<li id="menu-item-57578" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57578"><a target="_blank" href="http://www.hersamacorn.com/newspaper-advertising/">Advertise</a></li>
<li id="menu-item-61125" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children parent menu-item-61125"><a href="http://www.sheltonherald.com/help/">Help</a>
<ul class="sub-menu">
	<li id="menu-item-61144" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61144"><a href="http://www.sheltonherald.com/about-us/">About Us</a></li>
	<li id="menu-item-61143" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61143"><a href="http://www.sheltonherald.com/contact-us/">Contact Us</a></li>
	<li id="menu-item-61146" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61146"><a href="http://www.sheltonherald.com/news-submission-guide/">News Submission Guide</a></li>
	<li id="menu-item-61145" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61145"><a href="http://www.sheltonherald.com/submissions/">Submissions</a></li>
</ul>
</li>
</ul></div>
                    <div class="header-searchform">
                        <form method="get" action="http://www.sheltonherald.com">
                            <fieldset>
                                <input type="text" id="s" name="s" onfocus="if(this.value=='Search') this.value='';" onblur="if(this.value=='') this.value='Search';" value="Search" />
                                <button type="submit"></button>
                            </fieldset>
                        </form>
                    </div>
                </div>
                <div class="header-middle clear">
                
                <div class="header-adplace-left">
                        <div id="header-adplace-left">			<div class="execphpwidget"><!-- SheltonHeraldEarLeft -->
<div id='div-gpt-ad-1350414041047-4' style='width:180px; height:90px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1350414041047-4'); });
</script>
</div></div>
		</div>                    </div>
                    <div class="logo-header ">
                        <a href="http://www.sheltonherald.com">
                        <img src="http://sheltonherald.hanewsmedia.com/wp-content/uploads/sites/33/2015/09/SH-MAST-405.png" alt="Shelton Herald"/>                        </a>
                    </div>
                    <div class="header-adplace-right">
                        <div id="header-adplace-right">			<div class="execphpwidget"><!-- SheltonHeraldEarRight -->
<div id='div-gpt-ad-1350414041047-5' style='width:180px; height:90px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1350414041047-5'); });
</script></div></div>
		</div>                      
                    </div>
                </div>
            </div>

						<div id="navigation" class="menu-navigation clear"><ul id="menu-navigation" class="menu"><li id="menu-item-61053" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children parent menu-item-61053"><a href="http://www.sheltonherald.com/category/news/">News</a>
<ul class="sub-menu">
	<li id="menu-item-61124" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-61124"><a href="http://www.sheltonherald.com/category/news/police-fire/">Police &#038; Fire</a></li>
	<li id="menu-item-61068" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-61068"><a href="http://www.sheltonherald.com/category/news/business/">Business</a></li>
	<li id="menu-item-73810" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-73810"><a href="http://www.sheltonherald.com/category/news/community/">Community</a></li>
	<li id="menu-item-73811" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-73811"><a href="http://www.sheltonherald.com/category/news/entertainment/">Entertainment</a></li>
	<li id="menu-item-73812" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-73812"><a href="http://www.sheltonherald.com/category/news/people/">People</a></li>
	<li id="menu-item-61082" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-61082"><a href="http://www.sheltonherald.com/category/news/schools/">Schools</a></li>
	<li id="menu-item-61069" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-61069"><a href="http://www.sheltonherald.com/category/news/politics-elections/">Politics &#038; Elections</a></li>
	<li id="menu-item-61054" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-61054"><a target="_blank" href="http://www.hersamacorn.com/print-archives/">Print Archives</a></li>
	<li id="menu-item-61129" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61129"><a href="http://www.sheltonherald.com/submissions/">Submissions</a></li>
</ul>
</li>
<li id="menu-item-57609" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children parent menu-item-57609"><a href="http://sheltonherald.com/category/news/obituaries/">Obituaries</a>
<ul class="sub-menu">
	<li id="menu-item-57605" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-57605"><a href="http://www.sheltonherald.com/category/obituaries/">Latest Obituaries</a></li>
	<li id="menu-item-57610" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57610"><a href="https://hersamsecure.com/obit/">Submit an Obituary</a></li>
</ul>
</li>
<li id="menu-item-57602" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children parent menu-item-57602"><a href="http://www.sheltonherald.com/category/sports/">Sports</a>
<ul class="sub-menu">
	<li id="menu-item-57603" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-57603"><a href="http://www.sheltonherald.com/category/sports/high-school-sports/">High School Sports</a></li>
	<li id="menu-item-57604" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-57604"><a href="http://www.sheltonherald.com/category/sports/youth-sports/">Youth Sports</a></li>
	<li id="menu-item-73815" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-73815"><a href="http://www.sheltonherald.com/category/sports/sports-features/">Sports Features</a></li>
	<li id="menu-item-73814" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-73814"><a href="http://www.sheltonherald.com/category/sports/recreational-sports/">Recreational Sports</a></li>
	<li id="menu-item-73813" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-73813"><a href="http://www.sheltonherald.com/category/sports/other-sports/">Other Sports</a></li>
	<li id="menu-item-57657" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57657"><a href="http://www.sheltonherald.com/submissions/">Submissions</a></li>
</ul>
</li>
<li id="menu-item-61074" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-61074"><a href="http://www.sheltonherald.com/category/news/people/">People</a></li>
<li id="menu-item-61070" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children parent menu-item-61070"><a href="http://www.sheltonherald.com/category/opinion/">Opinion</a>
<ul class="sub-menu">
	<li id="menu-item-61073" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-61073"><a href="http://www.sheltonherald.com/category/opinion/letters/">Letters</a></li>
	<li id="menu-item-61072" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-61072"><a href="http://www.sheltonherald.com/category/opinion/editorial/">Editorial</a></li>
	<li id="menu-item-61071" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children parent menu-item-61071"><a href="http://www.sheltonherald.com/category/opinion/columns/">Columns</a>
	<ul class="sub-menu">
		<li id="menu-item-90211" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-90211"><a href="http://www.sheltonherald.com/category/opinion/columns/jim-cameron-talking-transportation/">Jim Cameron: Talking Transportation</a></li>
	</ul>
</li>
	<li id="menu-item-61131" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61131"><a href="http://www.sheltonherald.com/cartoon-gallery/">Cartoon Gallery</a></li>
</ul>
</li>
<li id="menu-item-73809" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children parent menu-item-73809"><a href="http://www.sheltonherald.com/events/">Happenings</a>
<ul class="sub-menu">
	<li id="menu-item-61111" class="menu-item menu-item-type-taxonomy menu-item-object-tribe_events_cat menu-item-61111"><a href="http://www.sheltonherald.com/events/category/community-events/">Community Events</a></li>
	<li id="menu-item-61115" class="menu-item menu-item-type-taxonomy menu-item-object-tribe_events_cat menu-item-61115"><a href="http://www.sheltonherald.com/events/category/library-events/">Library Events</a></li>
	<li id="menu-item-61128" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61128"><a href="http://www.sheltonherald.com/submissions/">Submissions</a></li>
</ul>
</li>
<li id="menu-item-71040" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children parent menu-item-71040"><a href="http://www.sheltonherald.com/category/al-columns/food/">Food</a>
<ul class="sub-menu">
	<li id="menu-item-71061" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-71061"><a href="http://www.sheltonherald.com/category/al-columns/al-twice-baked-twins/">Twins Judy &#038; Joy</a></li>
	<li id="menu-item-71056" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-71056"><a href="http://www.sheltonherald.com/category/al-columns/al-stir-crazy/">Stir Crazy</a></li>
	<li id="menu-item-71058" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-71058"><a href="http://www.sheltonherald.com/category/al-columns/al-the-conscious-cook/">The Conscious Cook</a></li>
</ul>
</li>
<li id="menu-item-71030" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children parent menu-item-71030"><a href="http://www.sheltonherald.com/category/al-features/">Arts</a>
<ul class="sub-menu">
	<li id="menu-item-71033" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-71033"><a href="http://www.sheltonherald.com/category/al-features/">Arts Features</a></li>
	<li id="menu-item-71055" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-71055"><a href="http://www.sheltonherald.com/category/al-columns/al-stage-screen/">Stage &#038; Screen</a></li>
	<li id="menu-item-71035" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children parent menu-item-71035"><a href="http://www.sheltonherald.com/category/al-columns/">Columns</a>
	<ul class="sub-menu">
		<li id="menu-item-71038" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-71038"><a href="http://www.sheltonherald.com/category/al-columns/al-did-i-say-that/">DId I Say That?</a></li>
		<li id="menu-item-71059" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-71059"><a href="http://www.sheltonherald.com/category/al-columns/al-the-reel-dad/">The Reel Dad</a></li>
		<li id="menu-item-71060" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-71060"><a href="http://www.sheltonherald.com/category/al-columns/al-tv-movie-menu/">TV / Movie Menu</a></li>
		<li id="menu-item-71037" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-71037"><a href="http://www.sheltonherald.com/category/al-columns/al-curtain-call/">Curtain Call</a></li>
		<li id="menu-item-71111" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-71111"><a href="http://www.sheltonherald.com/category/al-columns/al-stir-crazy/">Stir Crazy</a></li>
		<li id="menu-item-71113" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-71113"><a href="http://www.sheltonherald.com/category/al-columns/al-twice-baked-twins/">Twins Judy &#038; Joy</a></li>
		<li id="menu-item-71112" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-71112"><a href="http://www.sheltonherald.com/category/al-columns/al-the-conscious-cook/">The Conscious Cook</a></li>
		<li id="menu-item-71041" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-71041"><a href="http://www.sheltonherald.com/category/al-columns/al-go-fish/">Go Fish</a></li>
		<li id="menu-item-71057" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-71057"><a href="http://www.sheltonherald.com/category/al-columns/al-taking-a-hike/">Taking a Hike</a></li>
		<li id="menu-item-71036" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-71036"><a href="http://www.sheltonherald.com/category/al-columns/al-a-question-of-etiquette/">A Question of Etiquette</a></li>
	</ul>
</li>
	<li id="menu-item-71124" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-71124"><a href="http://arts.hersamacorn.com/events/">Events</a></li>
</ul>
</li>
<li id="menu-item-71039" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-71039"><a href="http://www.sheltonherald.com/category/al-columns/al-drive/">Automotive</a></li>
<li id="menu-item-61056" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children parent menu-item-61056"><a target="_blank" href="https://hersamsecure.com/classifieds/">Classifieds</a>
<ul class="sub-menu">
	<li id="menu-item-61057" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-61057"><a target="_blank" href="http://www.hersamacorn.com/classifiedadvertising/">Advertising Information</a></li>
	<li id="menu-item-61058" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-61058"><a href="https://classadz.vdata.com/HersamAcorn/UserType.aspx">Submit a Classified Ad</a></li>
</ul>
</li>
<li id="menu-item-57585" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children parent menu-item-57585"><a href="http://#">Special Sections</a>
<ul class="sub-menu">
	<li id="menu-item-98390" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-98390"><a href="http://goldenyears.han.network/">Golden Years</a></li>
	<li id="menu-item-57589" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57589"><a target="_blank" href="http://kidsworld.han.network/">Kid&#8217;s World</a></li>
	<li id="menu-item-57636" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57636"><a target="_blank" href="http://healthandfitness.han.network/">Health &#038; Fitness</a></li>
	<li id="menu-item-57588" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57588"><a target="_blank" href="http://bridal.han.network/">Bridal</a></li>
	<li id="menu-item-57639" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57639"><a target="_blank" href="http://education.han.network/">Education</a></li>
	<li id="menu-item-57642" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57642"><a target="_blank" href="http://arts.hersamacorn.com">Arts &#038; Leisure</a></li>
	<li id="menu-item-57586" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57586"><a target="_blank" href="http://thehomemonthly.com">HOME</a></li>
	<li id="menu-item-57587" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57587"><a target="_blank" href="http://sheltonanswerbook.com">Shelton Answerbook</a></li>
	<li id="menu-item-57592" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57592"><a target="_blank" href="http://hersamacorn.com/medical-services/">Your Health</a></li>
</ul>
</li>
</ul></div>						
	          <div class="middle clear">

                

<div id="content">


<div id="post-99787" class="single post-99787 post type-post status-publish format-standard hentry category-community category-lead-news">

    <div class="hentry-meta">
        <h1>Troop 28 cleans up for Earth Day, Clean Sweep</h1>
<h2></h2>
        <p class="hentry-meta-data">By <a class="url fn n" href="http://www.sheltonherald.com/author/shelton-herald-staff/" title="View all posts by Shelton Herald">Shelton Herald</a> on April 24, 2017 in <a href="http://www.sheltonherald.com/category/news/community/" rel="category tag">Community</a>, <a href="http://www.sheltonherald.com/category/lead-news/" rel="category tag">Lead News</a> &middot; <a href="#comments">0 Comments</a></p>
    </div>

    <div class="hentry-container clear">
                <div class="hentry-middle">
            <div class="hentry-content clear">
                <p><span style="font-weight: 400">On Saturday April 22 Boy Scout Troop 28 removed garbage from an open space area located near the Shelton Lakes Path in Shelton. At first the scouts found very little litter, which was a surprise, until they found a huge pile that someone must have dumped a while ago. The pile included six tires, vinyl siding, part of a large tractor, a furnace, two air conditioners, and a car transmission. </span></p>
<p><span style="font-weight: 400">Some neighbors questioned the scouts and thought they were illegally dumping garbage on the side of the road but they were pleasantly surprised to learn that they were in fact cleaning garbage from the trail. </span></p>
<p><span style="font-weight: 400">Scouts participating in the event included Nathan Ramos, Nicholas Cebrik, Isaac Seyer, AJ Corcino, Kyle Young, Joe Reilly, Ryan Rigoli, Nikolaus Wirth, Cameron Beecher, Joe LaRue, Reino Sawan, Michael Sawan, Eddie Balog, Luke Uhrynowski, and Michael Thomas.</span></p>
<p><span style="font-weight: 400">Troop 28 meets at 7 p.m. every Thursday at the Nike Site behind Mohegan School. For more information contact Paul Uhrynowski @ 203-521-4459.</span></p>
<div class='yarpp-related'>
<h3>Related posts:</h3><ol>
<li><a href="http://www.sheltonherald.com/35164/eat-chocolate-from-local-vendors-and-help-a-cause/" rel="bookmark" title="Eat chocolate from local vendors and help a cause">Eat chocolate from local vendors and help a cause </a></li>
<li><a href="http://www.sheltonherald.com/48344/area-reunions-set-over-the-next-few-months/" rel="bookmark" title="Area reunions set over the next few months">Area reunions set over the next few months </a></li>
<li><a href="http://www.sheltonherald.com/48410/observe-national-sickle-cell-awareness-donate-blood-with-american-red-cross/" rel="bookmark" title="Observe National Sickle Cell Awareness; donate blood with American Red Cross">Observe National Sickle Cell Awareness; donate blood with American Red Cross </a></li>
<li><a href="http://www.sheltonherald.com/58796/coaches-v-cancer-basketball-event-set-at-shelton-high/" rel="bookmark" title="‘Coaches v. Cancer’ basketball event set at Shelton High">‘Coaches v. Cancer’ basketball event set at Shelton High </a></li>
</ol>
</div>
            </div>
            <div class="hentry-footer">
                                                                <div class="hentry-navigation">
                    <div class="hentry-navigation-inn clear">
                                                    <a class="hentry-navigation-prev" href="http://www.sheltonherald.com/99784/obituary-paul-j-pj-mercier-78-of-huntington/">
                                <em>Previous Post</em>
                                <span>Obituary: Paul J. “PJ” Mercier, 78, of Huntington</span>
                            </a>
                                                    <a class="hentry-navigation-next" href="http://www.sheltonherald.com/99791/connecticut-is-third-best-state-for-childrens-health-care/">
                                <em>Next Post</em>
                                <span>Connecticut is third best state for children’s health care</span>
                            </a>
                                                    <div class="hentry-navigation-line"></div>
                    </div>
                </div>

              <!--  <div class='yarpp-related'>
<h3>Related posts:</h3><ol>
<li><a href="http://www.sheltonherald.com/35164/eat-chocolate-from-local-vendors-and-help-a-cause/" rel="bookmark" title="Eat chocolate from local vendors and help a cause">Eat chocolate from local vendors and help a cause </a></li>
<li><a href="http://www.sheltonherald.com/48344/area-reunions-set-over-the-next-few-months/" rel="bookmark" title="Area reunions set over the next few months">Area reunions set over the next few months </a></li>
<li><a href="http://www.sheltonherald.com/48410/observe-national-sickle-cell-awareness-donate-blood-with-american-red-cross/" rel="bookmark" title="Observe National Sickle Cell Awareness; donate blood with American Red Cross">Observe National Sickle Cell Awareness; donate blood with American Red Cross </a></li>
</ol>
</div>
-->

            </div>
        </div>
				        <div class="hentry-sidebar">
                        <div class="hentry-widget hentry-author">
                <h6>About author</h6>
                <div class="hentry-author-meta clear">
                    <img alt='Shelton Herald' src='http://sheltonherald.hanewsmedia.com/wp-content/uploads/sites/33/2015/02/Shelton-Herald_avatar_1425068061-60x60.png' class='avatar avatar-60 photo' height='60' width='60' />                    <p><a href="http://www.sheltonherald.com/author/shelton-herald-staff/">Shelton Herald</a></p>
                   <br />                 </div>
                <div class="hentry-author-about"></div>
            </div>
            
           <!--- -->

                        <div class="hentry-widget hentry-share">
                <h6>Share this article</h6>
                <ul>

                    <li class="twitter"><a href="http://twitter.com/share?text=Troop+28+cleans+up+for+Earth+Day%2C+Clean+Sweep&url=http%3A%2F%2Fwww.sheltonherald.com%2F99787%2Ftroop-28-cleans-up-for-earth-day-clean-sweep%2F" target="_blank" rel="external nofollow">Tweet this</a></li>
           
                    <li class="fb"><a href="http://facebook.com/share.php?u=http://www.sheltonherald.com/99787/troop-28-cleans-up-for-earth-day-clean-sweep/&amp;t=Troop+28+cleans+up+for+Earth+Day%2C+Clean+Sweep" target="_blank" rel="external nofollow">Share on Facebook</a></li>
                    <li class="stumbleupon"><a href="http://stumbleupon.com/submit?url=http://www.sheltonherald.com/99787/troop-28-cleans-up-for-earth-day-clean-sweep/&amp;title=Troop+28+cleans+up+for+Earth+Day%2C+Clean+Sweep" target="_blank" rel="external nofollow">Stumble it</a></li>
   
                    <li class="feed"><a href="http://www.sheltonherald.com/feed/">Subscribe by RSS</a></li>
										<li class="google"><a href="https://plusone.google.com/_/+1/confirm?hl=en&url=http://www.sheltonherald.com/99787/troop-28-cleans-up-for-earth-day-clean-sweep/" target="_blank" rel="external nofollow">Share on Google</a></a>
                </ul>
            </div>
            
            
        </div>
				
        
    </div>

    <div class="clear"></div>
    
    <div class="agree"><p>By participating in the comments section of this site you are agreeing to our <a href="http://www.ncadvertiser.com/user-agreement-privacy-policy/">Privacy Policy and User Agreement</a></p></div>

    
<div id="disqus_thread">
    </div>


</div> <!-- .single -->


</div><!-- #content -->

<div id="sidebar">
    <div id="execphp-9" class="widget_execphp widget">			<div class="execphpwidget"><a href="http://live.han.network"><img src="http://sheltonherald.hanewsmedia.com/wp-content/uploads/sites/33/2016/09/han-network-banner-v1-opt.png" alt="Live HAN Network" width="300" height="90" class="aligncenter size-full wp-image-92459" /></a></div>
		</div><div id="execphp-10" class="widget_execphp widget">			<div class="execphpwidget"><div style="padding-top:10px;">
<a href="http://live.han.network/schedule/" rel="attachment wp-att-486978"><img src="http://hanradio.hanewsmedia.com/wp-content/uploads/sites/46/2016/01/programschedule.jpg" alt="programschedule" width="300" height="40" class="aligncenter size-full wp-image-486978" /></a></div></div>
		</div><div id="execphp-2" class="widget_execphp widget">			<div class="execphpwidget"><div style="padding-bottom:15px;padding-top:15px;">
<!-- SheltonHeraldSquare1 -->
<div id='div-gpt-ad-1350414041047-9' style='width:300px; height:250px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1350414041047-9'); });
</script>
</div></div>
<div style="padding-bottom:15px;">
<!-- SheltonHeraldRectangle1 -->
<div id='div-gpt-ad-1350414041047-6' style='width:300px; height:75px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1350414041047-6'); });
</script>
</div></div>
<div style="padding-bottom:15px;">
<!-- SheltonHeraldSquare2 -->
<div id='div-gpt-ad-1350414041047-10' style='width:300px; height:250px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1350414041047-10'); });
</script>
</div></div></div>
		</div><div id="execphp-8" class="widget_execphp widget"><h3 class="widget-title">Latest Tweets</h3>			<div class="execphpwidget">            <a class="twitter-timeline"  href="https://twitter.com/SheltonHerald" data-widget-id="654001949151490048">Tweets by @SheltonHerald</a>
            <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+"://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>
          </div>
		</div><div id="execphp-3" class="widget_execphp widget">			<div class="execphpwidget"><div style="padding-bottom:15px; padding-top:15px;">
<!-- SheltonHeraldSquare3 -->
<div id='div-gpt-ad-1350414041047-11' style='width:300px; height:250px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1350414041047-11'); });
</script>
</div></div>
<div style="padding-bottom:15px;">
<!-- SheltonHeraldRectangle2 -->
<div id='div-gpt-ad-1350414041047-7' style='width:300px; height:75px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1350414041047-7'); });
</script>
</div></div>
<div style="padding-bottom:15px;">
<!-- SheltonHeraldSquare4 -->
<div id='div-gpt-ad-1350414041047-12' style='width:300px; height:250px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1350414041047-12'); });
</script>
</div></div>
<div style="padding-bottom:15px;">
<!-- SheltonHeraldSquare5 -->
<div id='div-gpt-ad-1350414041047-17' style='width:300px; height:250px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1350414041047-17'); });
</script>
</div></div></div>
		</div><div id="text-6" class="widget_text widget">			<div class="textwidget"><a href="http://feeds.feedburner.com/SheltonHeraldNews" target="_blank"><img class="alignleft size-full wp-image-24531" style="margin-right: 10px;" alt="news-rss" src="http://hersamacorn.com/img/news-rss.jpg" width="145" height="30" /></a><a href="http://feeds.feedburner.com/SheltonHeraldSports" target="_blank"><img alt="sports-rss" src="http://hersamacorn.com/img/sports-rss.jpg" width="145" height="30" /></a></div>
		</div></div><!-- #sidebar -->

            </div> <!-- .middle -->
            <div class="bottom-widgetarea">
                <div class="bottom-widgetarea-inn clear">

                                                        </div>
            </div>
            <div class="footer clear">

            
                <div class="footer-leftpart">
                    <a class="logo-footer" href="http://www.sheltonherald.com">
                        <img src="http://sheltonherald.hanewsmedia.com/wp-content/uploads/sites/33/2015/08/shelton-hannetwork-bottom.png" alt="Shelton Herald"/>                    </a>
                </div>
                <div class="footer-middlepart">
					<div id="footer-widget">			<div class="textwidget"><div class="footlist"><p><a href="http://www.hersamacorn.com"><strong>HAN Network News Sites</strong></a>
</p>
<p><strong><a href="http://live.han.network">Live.HAN.Network</a></strong> | <a href="http://www.thebridgeportnews.com">Bridgeport News</a> | <a href="http://www.darientimes.com">Darien Times</a><br />
  <a href="http://www.eastoncourier.com">Easton Courier</a> | <a href="http://www.fairfield-sun.com">Fairfield Sun</a> | <a href="http://www.greenwich-post.com">Greenwich Post</a><br />    <a href="http://www.lewisboroledger.com">Lewisboro Ledger</a>  |  <a href="http://www.milfordmirror.com">Milford Mirror</a>  |  
  <a href="http://www.monroecourier.com">Monroe Courier</a><br /><a href="http://www.ncadvertiser.com">New Canaan Advertiser</a>  |  <a href="http://www.thereddingpilot.com">Redding Pilot</a>  |  
  <a href="http://www.theridgefieldpress.com">Ridgefield Press</a><br /><a href="http://www.sheltonherald.com">Shelton Herald</a>  |  
<a href="http://www.stratfordstar.com">Stratford Star</a>  |  <a href="http://www.trumbulltimes.com">Trumbull Times </a><br />
<a href="http://www.thewestonforum.com">Weston Forum</a>  |  <a href="http://www.wiltonbulletin.com">Wilton Bulletin
  </a>
</p></div></div>
		</div>                </div>

            <ul id="menu-footer-left-linkset" class="footer-linkset"><li id="menu-item-60935" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-60935"><a target="_blank" href="http://arts.hersamacorn.com">Arts &#038; Leisure</a></li>
<li id="menu-item-57515" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57515"><a target="_blank" href="http://www.hersamacorn.com/newspaper-advertising/">Advertise</a></li>
<li id="menu-item-57516" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57516"><a target="_blank" href="https://hersamsecure.com/classifieds/">Classifieds</a></li>
<li id="menu-item-57518" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57518"><a target="_blank" href="http://www.hersamacorn.com/article-reprints/">Article Reprints</a></li>
<li id="menu-item-57519" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57519"><a target="_blank" href="http://www.hersamacorn.com/print-archives/">Print Archives</a></li>
<li id="menu-item-57520" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57520"><a target="_blank" href="https://classadz.vdata.com/HersamAcornCirc/SelectOption.aspx">Subscriptions</a></li>
<li id="menu-item-61142" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61142"><a href="http://www.sheltonherald.com/privacy-policy-user-agreement/">Privacy Policy &#038; User Agreement</a></li>
</ul>
            <ul id="menu-footer-right-linkset" class="footer-linkset"><li id="menu-item-57521" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57521"><a target="_blank" href="https://twitter.com/SheltonHerald">Follow us on Twitter</a></li>
<li id="menu-item-57570" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57570"><a target="_blank" href="https://www.facebook.com/SheltonHerald">Like us on Facebook</a></li>
<li id="menu-item-57571" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57571"><a target="_blank" href="http://www.sheltonanswerbook.com">Shelton Answerbook</a></li>
<li id="menu-item-57666" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57666"><a href="http://www.sheltonherald.com/contact-us/">Contact Us</a></li>
<li id="menu-item-61140" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61140"><a href="http://www.sheltonherald.com/submissions/">Submissions</a></li>
<li id="menu-item-61141" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61141"><a href="http://www.sheltonherald.com/site-map/">Site Map</a></li>
</ul>
            </div><!-- .footer -->
            <div class="copyrights">
                <!-- <p><a href="http://www.sheltonherald.com">Shelton Herald</a> &copy; 2017 All Rights Reserved</p> -->
                <p>© HAN Network. All rights reserved. Shelton Herald, 1000 Bridgeport Avenue, Shelton, CT 06484</p>            </div>
            <div class="credits">
                <p>Designed by <a href="http://wpshower.com">WPSHOWER</a></p>
                <p>Powered by <a href="http://wordpress.org">WordPress</a></p>
            </div>
            <div class="clear"></div>
        </div> <!-- .wrapper -->

        <script type="text/javascript">if(window.aiModifyParent) {aiModifyParent();}</script>
<!-- WP Audio player plugin v1.9.6 - https://www.tipsandtricks-hq.com/wordpress-audio-music-player-plugin-4556/ -->
    <script type="text/javascript">
        soundManager.useFlashBlock = true; // optional - if used, required flashblock.css
        soundManager.url = 'http://sheltonherald.hanewsmedia.com/wp-content/plugins/compact-wp-audio-player/swf/soundmanager2.swf';
        function play_mp3(flg, ids, mp3url, volume, loops)
        {
            //Check the file URL parameter value
            var pieces = mp3url.split("|");
            if (pieces.length > 1) {//We have got an .ogg file too
                mp3file = pieces[0];
                oggfile = pieces[1];
                //set the file URL to be an array with the mp3 and ogg file
                mp3url = new Array(mp3file, oggfile);
            }

            soundManager.createSound({
                id: 'btnplay_' + ids,
                volume: volume,
                url: mp3url
            });

            if (flg == 'play') {
                    soundManager.play('btnplay_' + ids, {
                    onfinish: function() {
                        if (loops == 'true') {
                            loopSound('btnplay_' + ids);
                        }
                        else {
                            document.getElementById('btnplay_' + ids).style.display = 'inline';
                            document.getElementById('btnstop_' + ids).style.display = 'none';
                        }
                    }
                });
            }
            else if (flg == 'stop') {
    //soundManager.stop('btnplay_'+ids);
                soundManager.pause('btnplay_' + ids);
            }
        }
        function show_hide(flag, ids)
        {
            if (flag == 'play') {
                document.getElementById('btnplay_' + ids).style.display = 'none';
                document.getElementById('btnstop_' + ids).style.display = 'inline';
            }
            else if (flag == 'stop') {
                document.getElementById('btnplay_' + ids).style.display = 'inline';
                document.getElementById('btnstop_' + ids).style.display = 'none';
            }
        }
        function loopSound(soundID)
        {
            window.setTimeout(function() {
                soundManager.play(soundID, {onfinish: function() {
                        loopSound(soundID);
                    }});
            }, 1);
        }
        function stop_all_tracks()
        {
            soundManager.stopAll();
            var inputs = document.getElementsByTagName("input");
            for (var i = 0; i < inputs.length; i++) {
                if (inputs[i].id.indexOf("btnplay_") == 0) {
                    inputs[i].style.display = 'inline';//Toggle the play button
                }
                if (inputs[i].id.indexOf("btnstop_") == 0) {
                    inputs[i].style.display = 'none';//Hide the stop button
                }
            }
        }
    </script>
    <script>window._popup_data = {"ajaxurl":"http:\/\/www.sheltonherald.com\/wp-admin\/admin-ajax.php","do":"get_data","ajax_data":{"orig_request_uri":"\/99787\/troop-28-cleans-up-for-earth-day-clean-sweep\/"}};</script><link rel='stylesheet' id='yarppRelatedCss-css'  href='http://www.sheltonherald.com/wp-content/plugins/yet-another-related-posts-plugin/style/related.css?ver=acdaae8ca8ba9e4909e785333059eb2c' type='text/css' media='all' />
<script type='text/javascript' src='http://platform.twitter.com/widgets.js?ver=acdaae8ca8ba9e4909e785333059eb2c'></script>
<script type='text/javascript' src='http://apis.google.com/js/plusone.js?ver=acdaae8ca8ba9e4909e785333059eb2c'></script>
<script type='text/javascript' src='http://platform.linkedin.com/in.js?ver=acdaae8ca8ba9e4909e785333059eb2c'></script>
<script type='text/javascript' src='http://www.sheltonherald.com/wp-includes/js/comment-reply.min.js?ver=acdaae8ca8ba9e4909e785333059eb2c'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201717'></script>
<script type='text/javascript' src='http://www.sheltonherald.com/wp-content/plugins/youtube-embed-plus-pro/scripts/fitvids.min.js?ver=acdaae8ca8ba9e4909e785333059eb2c'></script>
<script type='text/javascript' src='http://sheltonherald.hanewsmedia.com/wp-content/plugins/popover/js/public.min.js?ver=acdaae8ca8ba9e4909e785333059eb2c'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var author = {"name":"Shelton Herald"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.sheltonherald.com/wp-content/themes/unspoken-sh/lib/js/google.js?ver=1.0.0'></script>
<script type='text/javascript' src='http://www.sheltonherald.com/wp-includes/js/wp-embed.min.js?ver=acdaae8ca8ba9e4909e785333059eb2c'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"platform":"wordpress@4.7.4","language":""},"disqusIdentifier":"99787 http:\/\/www.sheltonherald.com\/?p=99787","disqusShortname":"sheltonherald","disqusTitle":"Troop 28 cleans up for Earth Day, Clean Sweep","disqusUrl":"http:\/\/www.sheltonherald.com\/99787\/troop-28-cleans-up-for-earth-day-clean-sweep\/","options":{"manualSync":false},"postId":"99787"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.sheltonherald.com/wp-content/plugins/disqus-comment-system/media/js/disqus.js?ver=acdaae8ca8ba9e4909e785333059eb2c'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"sheltonherald"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.sheltonherald.com/wp-content/plugins/disqus-comment-system/media/js/count.js?ver=acdaae8ca8ba9e4909e785333059eb2c'></script>

        
	</body>
</html>
